Bug 1011953 - [abrt] ibus-1.5.3-1.fc19: switcher_run: Process /usr/libexec/ibus-ui-gtk3 was killed by signal 6 (SIGABRT) [NEEDINFO]
[abrt] ibus-1.5.3-1.fc19: switcher_run: Process /usr/libexec/ibus-ui-gtk3 was...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:e8dc3c2cd7f17bd89bfaa9344e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 08:42 EDT by Ming Yang
Modified: 2013-12-11 04:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 04:10:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tfujiwar: needinfo? (myang)


Attachments (Terms of Use)
File: backtrace (22.50 KB, text/plain)
2013-09-25 08:42 EDT, Ming Yang
no flags Details
File: cgroup (141 bytes, text/plain)
2013-09-25 08:42 EDT, Ming Yang
no flags Details
File: core_backtrace (12.73 KB, text/plain)
2013-09-25 08:42 EDT, Ming Yang
no flags Details
File: dso_list (8.07 KB, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: environ (970 bytes, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: maps (42.24 KB, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: open_fds (622 bytes, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details
File: var_log_messages (255 bytes, text/plain)
2013-09-25 08:43 EDT, Ming Yang
no flags Details

  None (edit)
Description Ming Yang 2013-09-25 08:42:44 EDT
Version-Release number of selected component:
ibus-1.5.3-1.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/libexec/ibus-ui-gtk3
crash_function: switcher_run
executable:     /usr/libexec/ibus-ui-gtk3
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 switcher_run at switcher.c:313
 #5 panel_handle_engine_switch at panel.c:3761
 #6 keybinding_manager_event_handler at keybindingmanager.c:622
 #7 _keybinding_manager_event_handler_gdk_event_func at keybindingmanager.c:151
 #13 switcher_run at switcher.c:456
 #14 panel_handle_engine_switch at panel.c:3761
 #15 keybinding_manager_event_handler at keybindingmanager.c:622
 #16 _keybinding_manager_event_handler_gdk_event_func at keybindingmanager.c:151
 #22 gtk_main at gtkmain.c:1156
 #23 application_run at application.c:217
Comment 1 Ming Yang 2013-09-25 08:42:49 EDT
Created attachment 802819 [details]
File: backtrace
Comment 2 Ming Yang 2013-09-25 08:42:53 EDT
Created attachment 802820 [details]
File: cgroup
Comment 3 Ming Yang 2013-09-25 08:42:56 EDT
Created attachment 802821 [details]
File: core_backtrace
Comment 4 Ming Yang 2013-09-25 08:43:00 EDT
Created attachment 802822 [details]
File: dso_list
Comment 5 Ming Yang 2013-09-25 08:43:03 EDT
Created attachment 802823 [details]
File: environ
Comment 6 Ming Yang 2013-09-25 08:43:06 EDT
Created attachment 802824 [details]
File: limits
Comment 7 Ming Yang 2013-09-25 08:43:10 EDT
Created attachment 802825 [details]
File: maps
Comment 8 Ming Yang 2013-09-25 08:43:16 EDT
Created attachment 802826 [details]
File: open_fds
Comment 9 Ming Yang 2013-09-25 08:43:20 EDT
Created attachment 802827 [details]
File: proc_pid_status
Comment 10 Ming Yang 2013-09-25 08:43:23 EDT
Created attachment 802828 [details]
File: var_log_messages
Comment 11 fujiwara 2013-09-27 02:36:20 EDT
(In reply to Ming Yang from comment #1)
> Created attachment 802819 [details]
> File: backtrace

> #0  0x000000331e635a19 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
> #1  0x000000331e637128 in __GI_abort () at abort.c:90
> #2  0x0000003320a6bbc6 in g_assertion_message (domain=domain@entry=0x41947d "IBUS", file=file@entry=0x41c181 "switcher.c", line=line@entry=313, func=func@entry=0x41c541 <__PRETTY_FUNCTION__.51264> "switcher_run", message=<optimized out>) at gtestutils.c:1912
> #3  0x0000003320a6bc24 in g_assertion_message_expr (domain=domain@entry=0x41947d "IBUS", file=file@entry=0x41c181 "switcher.c", line=line@entry=313, func=func@entry=0x41c541 <__PRETTY_FUNCTION__.51264> "switcher_run", expr=expr@entry=0x41c172 "m_loop == null") at gtestutils.c:1923
> #4  0x0000000000415ed2 in switcher_run (self=0x2378210, keyval=keyval@entry=32, state=<optimized out>, event=event@entry=0x39e5ab0, engines=<optimized out>, engines_length1=2, index=1) at switcher.c:313


I cannot reproduce your backtrace.
Are you still able to reproduce your problem?

Note You need to log in before you can comment on or make changes to this bug.