Bug 1011998 - Foreman environments - don't create for every Katello environment created
Foreman environments - don't create for every Katello environment created
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 10:10 EDT by Brad Buckingham
Modified: 2014-04-24 13:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-09-25 10:10:10 EDT
Description of problem:

Currently, whenever an environment is created in Katello a corresponding environment is created in Foreman.  This made sense in MDP1, since each environment in Katello would have a 'default content view' associated with it and Foreman environments effectively mapped to content views.  In MDP2, 'legacy promotion' of products/repositories was removed; therefore, a default content view is only created for Library and not for any other environment; therefore, it may no longer make sense to create these Foreman environments (e.g. for dev, test, prod...etc).

Version-Release number of selected component (if applicable):
katello-1.4.6-9.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. in Katello, create a 'dev' environment within organization 'ACME_Corporation'

Actual results:
in Foreman, the following environment is created: KT_ACME_Corporation_dev_env

Expected results:
an environment does not need to be created in Foreman

Additional info:

This would likely require changes to katello and katello-foreman-engine.  Also, need to make sure we address the issue for both environment create & destroy.
Comment 2 Ivan Necas 2013-10-02 07:20:29 EDT
The one thing that it makes sense to have it in Foreman is that the foreman-katello-engine relies on it to show the structure in select box for puppet environment:

  org
    dev
      cv
    test
      cv

I can disable selecting the environment when creating a host. On the other hand, since this particular thing will for sure change after enginification effort, I would suggest not being able to select the environment for host group or host as sufficient fix for MDP2, comparing the effort needed for removing this completely.
Comment 3 Mike McCune 2013-10-15 01:15:18 EDT
moving this to MDP3 since Ivan is re-working the env selector in a different bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1018919
Comment 4 Ivan Necas 2013-10-15 08:58:46 EDT
The issue was addressed as part of https://bugzilla.redhat.com/show_bug.cgi?id=1018919 and should be fixed together with that bug.
Comment 5 Ivan Necas 2013-10-16 05:22:14 EDT
Fixed as part of https://bugzilla.redhat.com/show_bug.cgi?id=1018919
Comment 8 Og Maciel 2013-10-21 17:56:39 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 9 Bryan Kearney 2014-04-24 13:09:55 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 10 Bryan Kearney 2014-04-24 13:11:17 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.