Bug 1012106 - [RFE] WebAdmin: can change host cluster only from certain places in the UI and not others
[RFE] WebAdmin: can change host cluster only from certain places in the UI an...
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: nobody nobody
Pavel Stehlik
: FutureFeature, Improvement, UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 13:39 EDT by mrao
Modified: 2017-05-15 02:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-15 02:33:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Comment 1 Itamar Heim 2013-09-26 10:29:40 EDT
Description of problem:
Select a host node on tree and try to edit and change the host cluster, and you can't since this option is disabled in the properties. But if you choose the System Node on the tree, and then navigate to the host tab and edit, you can change the host cluster
Comment 2 Itamar Heim 2013-09-26 10:31:53 EDT
einav, iirc, this is because we always disable in dialogs fields affecting the location of the entity.
i.e., if user changes the cluster, while standing on a the host under the cluster tree node, the host should disappear from the tree to the newly chosen cluster
Comment 3 Einav Cohen 2013-10-02 20:42:05 EDT
(In reply to Itamar Heim from comment #2)
> einav, iirc, this is because we always disable in dialogs fields affecting
> the location of the entity.
> i.e., if user changes the cluster, while standing on a the host under the
> cluster tree node, the host should disappear from the tree to the newly
> chosen cluster

correct.
while a specific tree-node is selected, the main-tabs panel is in a specific context determined by that tree-node; e.g. when standing on a certain cluster in the tree, the Hosts main tab is displaying only Hosts within that cluster. Selecting one of these Hosts *in this context* and changing its cluster will result in removing the Host from the current context, i.e. it will disappear from the main tab, its location within the left-pane tree will have to change, etc.

I suggest to either close this bug, or come up with a comprehensive solution that will allow us to do out-of-context changes to business entities.
Comment 4 Arthur Berezin 2013-10-07 05:43:49 EDT
Einav, I think Elan had some ideas around this.
Comment 6 Arthur Berezin 2014-02-02 10:59:42 EST
Einav, is it problematic to select a cluster and move it's hosts to another cluster? It seems like the desired behaviour here. If we take filesystem management as an analogy, it would be similar to "right click > move to..." which would remove the object from current view.
Comment 7 Einav Cohen 2014-02-02 12:14:49 EST
(In reply to Arthur Berezin from comment #6)
> Einav, is it problematic to select a cluster and move it's hosts to another
> cluster? It seems like the desired behaviour here. If we take filesystem
> management as an analogy, it would be similar to "right click > move to..."
> which would remove the object from current view.

if it is OK from the user's perspective that the Host that he just saw in the grid is disappearing from the grid all of a sudden (since the grid shows only Hosts in Cluster X and the Host is now in Cluster Y) - no problem. IMO - it is not OK.
Comment 9 Oved Ourfali 2017-05-15 02:33:40 EDT
in 4.2 we're removing the system tree, so this will no longer be relevant.

Note You need to log in before you can comment on or make changes to this bug.