Bug 1012145 - [RHS-C] Make Red Hat Plug-in a requirement for Red Hat Storage
[RHS-C] Make Red Hat Plug-in a requirement for Red Hat Storage
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Bala.FA
Prasanth
: ZStream
Depends On:
Blocks: 1012144
  Show dependency treegraph
 
Reported: 2013-09-25 16:04 EDT by Jeffrey McGowan
Modified: 2015-05-15 14:35 EDT (History)
12 users (show)

See Also:
Fixed In Version: rhsc-2.1.2-0.23.master.el6_5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:40:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The fix is attached (773 bytes, patch)
2013-11-07 06:37 EST, Bala.FA
no flags Details | Diff

  None (edit)
Description Jeffrey McGowan 2013-09-25 16:04:53 EDT
We want to make the Red Hat Plug-in a requirement for Red Hat Storage because it will increase usage and will reduce some clunky things we had to do while in tech-preview.  

We propose that we do for RHS *exactly* what we are doing with RHEV 3.3 (this makes sense because RHEV and RHS are functionally the same)


Description of problem:

Add the following lines to application.xml such that RHS ear file will load the redhat-access-plugin-storage. 

This change will negate the need for the redhat-access-plugin-storage SPEC file to modify this configuration file during its installation.


<module> 
  <web>
     <web-uri>redhat-access-plugin-storage.war</web-uri> 
     <context-root>/redhat-access-plugin-storage</context-root> 
  </web>
</module>
Comment 2 Scott Haines 2013-09-25 16:43:43 EDT
Targeting for Corbett.
Comment 3 Bala.FA 2013-10-21 04:43:01 EDT
The fix is sent for review.  rhsc-engine now depends on redhat-access-plugin-storage
Comment 5 Dustin Tsang 2013-10-28 12:30:39 EDT
entry for redhat-access-plugin-storage.war in application.xml of the exploded ear @/usr/share/ovirt-engine/engine.ear/META-INF/application.xml not seen in the latest build (rhsc-cb5)

am I looking in the right place for the change?
Comment 6 Bala.FA 2013-10-28 21:21:21 EDT
There was build issues with this dependency and removed at last minute.  This will be fixed in upcoming builds.
Comment 7 Bala.FA 2013-11-07 06:32:20 EST
fix is sent for review
Comment 8 Bala.FA 2013-11-07 06:37:45 EST
Created attachment 821033 [details]
The fix is attached
Comment 9 Keith Robertson 2013-11-07 08:19:42 EST
(In reply to Bala.FA from comment #8)
> Created attachment 821033 [details]
> The fix is attached

Patch looks good and it would pull in the appropriate RPM.  ACK.
Comment 10 Prasanth 2013-11-14 07:09:52 EST
Verified in rhsc-2.1.2-0.23.master.el6_5

rhsc-engine now depends on redhat-access-plugin-rhsc
Comment 11 Keith Robertson 2014-01-07 10:13:17 EST
FYI: We created a Knowledgebase article in the Red Hat Customer Portal which described the plug-in.  

[1] https://access.redhat.com/site/articles/473823
Comment 13 errata-xmlrpc 2014-02-25 02:40:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.