Bug 1012160 - Error for importing individual package/module is not rendered correctly
Error for importing individual package/module is not rendered correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 16:48 EDT by Og Maciel
Modified: 2014-07-02 10:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:08:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (111.51 KB, image/png)
2013-09-25 16:48 EDT, Og Maciel
no flags Details
successfully uploaded a module (49.48 KB, image/png)
2014-05-07 04:24 EDT, Sachin Ghai
no flags Details
error is properly displayed on UI (58.41 KB, image/png)
2014-05-07 04:25 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Og Maciel 2013-09-25 16:48:47 EDT
Created attachment 803088 [details]
Screenshot

Description of problem:

The attached screenshot shows that the error displayed in the UI for a failed import of a package is not being rendered correctly.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-5.el6sat.noarch
* foreman-compute-1.3.0-5.el6sat.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.3.0-5.el6sat.noarch
* foreman-postgresql-1.3.0-5.el6sat.noarch
* foreman-proxy-1.3.0-1.el6sat.noarch
* katello-1.4.6-9.el6sat.noarch
* katello-all-1.4.6-9.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-13.el6sat.noarch
* katello-cli-common-1.4.3-13.el6sat.noarch
* katello-common-1.4.6-9.el6sat.noarch
* katello-configure-1.4.5-8.el6sat.noarch
* katello-configure-foreman-1.4.5-8.el6sat.noarch
* katello-configure-foreman-proxy-1.4.5-8.el6sat.noarch
* katello-foreman-all-1.4.6-9.el6sat.noarch
* katello-glue-candlepin-1.4.6-9.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-9.el6sat.noarch
* katello-glue-pulp-1.4.6-9.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.14.alpha.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.14.alpha.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.14.alpha.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.14.alpha.el6sat.noarch
* pulp-selinux-2.3.0-0.14.alpha.el6sat.noarch
* pulp-server-2.3.0-0.14.alpha.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.20-3.el6sat.noarch
* signo-katello-0.0.20-3.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. You need to import an individual package or puppet module and it has to fail (I used https://github.com/pulp/pulp_puppet/blob/master/pulp_puppet_plugins/test/data/good-modules/adob-good/pkg/adob-good-2.0.0.tar.gz)
2.
3.

Actual results:

Error message is not rendered correctly

Expected results:


Additional info:
Comment 2 Eric Helms 2013-10-02 22:00:46 EDT
I tested this on latest and was not able to reproduce. Recent work in this area may have addressed this issue indirectly. Please re-test.
Comment 4 Sachin Ghai 2014-05-07 04:24:10 EDT
Verified with Satellite-6.0.3-RHEL-6-20140430.4


I uploaded two modules.. one was successfully uploaded and other the one pointed in defect description "adob-good-2.0.0.tar.gz" raised proper error on UI. Looks like reported issue is fixed, so moving this to verified.
Comment 5 Sachin Ghai 2014-05-07 04:24:51 EDT
Created attachment 893155 [details]
successfully uploaded a module
Comment 6 Sachin Ghai 2014-05-07 04:25:47 EDT
Created attachment 893156 [details]
error is properly displayed on UI
Comment 7 Bryan Kearney 2014-07-02 10:08:13 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 8 Bryan Kearney 2014-07-02 10:09:36 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0

Note You need to log in before you can comment on or make changes to this bug.