Bug 1012179 - gv not opening eps files in fedora 19
gv not opening eps files in fedora 19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gv (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 18:31 EDT by trilo
Modified: 2013-09-27 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 15:52:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ghostscript 1 None None None Never

  None (edit)
Description trilo 2013-09-25 18:31:29 EDT
Description of problem:I have installed fedora 19. I am not able to open eps file in gv. It gives the following message:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Error: /invalidfont in /findfont
Operand stack:
   Symbol-Oblique   Symbol
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1884   1   3   %oparray_pop   1883   1   3   %oparray_pop   1867   1   3   %oparray_pop   1755   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1836   2   4   %oparray_pop
Dictionary stack:
   --dict:1167/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:175/256(L)--
Current allocation mode is local
Last OS error: Not a directory
GPL Ghostscript 9.07: Unrecoverable error, exit code 1



Version-Release number of selected component (if applicable):


How reproducible:Always


Steps to Reproduce:
1.open konsole
2.type gv filename.eps
3.

Actual results:shows nothing


Expected results: display text and graphics


Additional info: the same file opens in other system
Comment 1 Orion Poplawski 2013-09-25 19:07:15 EDT
Please attach your eps file.

FYI, these:

Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.

are caused by having a ~/.fonts.conf file, which probably should be removed.

It's possible that doing a:

yum install 'font(symbol)'

will install the missing font.
Comment 2 trilo 2013-09-27 13:33:12 EDT
Thank you for the reply.
After removing .font.conf and indtalling font(symbol) it gives the following error:

Error: /invalidfont in /findfontGPL Ghostscript 9.07: Unrecoverable error, exit code 1

Operand stack:
   Symbol-Oblique   Symbol
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1884   1   3   %oparray_pop   1883   1   3   %oparray_pop   1867   1   3   %oparray_pop   1755   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1836   2   4   %oparray_pop
Dictionary stack:
   --dict:1167/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:175/256(L)--
Current allocation mode is local
Last OS error: Not a directory

Actually the .eps file is a sine curve generated by gnuplot!
Please help.
Comment 3 Orion Poplawski 2013-09-27 13:40:22 EDT
Please attach the eps files *and* instructions for generating it.
Comment 4 trilo 2013-09-27 14:08:21 EDT
The problem is solved by just emptying /var/cache/fontconfig directory.
Thanks to Jerry James!

https://bugzilla.redhat.com/show_bug.cgi?id=921706

Note You need to log in before you can comment on or make changes to this bug.