Bug 1012187 - RFE - automatically add Topic Title based on <title> tag
RFE - automatically add Topic Title based on <title> tag
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.1
Unspecified Unspecified
low Severity low
: ---
: 1.2
Assigned To: Matthew Casperson
:
: 1012237 (view as bug list)
Depends On:
Blocks: 979871 1013825
  Show dependency treegraph
 
Reported: 2013-09-25 19:47 EDT by Ruediger Landmann
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2013-09-25 19:47:28 EDT
Description of problem:
When you create a new topic, and try to save, PressGang disallows the save with an error that says:

"The Topic Title field is a mandatory field and cannot be empty." 

Since most (all?) topics stored in the database have a formal element as their root node and have a <title> child element, PressGang could default to using the contents of that element without interrupting the user. 

Version-Release number of selected component (if applicable):
Build 201309081012

How reproducible:
100%

Steps to Reproduce:
1. Create a new topic with a <title> child element
2. Click "Save"

Actual results:
PressGang disallows the save

Expected results:
PressGang takes advantage of the information already available to it

Additional info:
The error message doesn't tell the user where to go or how to fix the problem.
Comment 1 Lee Newson 2013-09-26 00:50:22 EDT
*** Bug 1012237 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Casperson 2013-10-02 23:18:27 EDT
Fixed in 201310031139

When a value is entered (for new topics) or changed (in existing topics) in the properties tab, that takes precidence over the <title> element in the XML.

If no title is specified or changed, the title will reflect the one in the XML if the XML is valid, is a section, and has a title element as the first child.
Comment 4 Matthew Casperson 2013-10-07 23:17:18 EDT
Hours apply to 2013-10-02

Note You need to log in before you can comment on or make changes to this bug.