This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012199 - Publican fails to work after yum update
Publican fails to work after yum update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: publican (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 22:04 EDT by Andrew Ross
Modified: 2013-10-20 18:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 23:08:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Ross 2013-09-25 22:04:53 EDT
Description of problem: A normal yum update pulled in publican-3.2.1-0.fc19.noarch. Publican now fails to work.

For example, creating a book:
publican create --type Book --name "Testing" --lang en-US
	Processing file en-US/Author_Group.xml -> en-US/Author_Group.xml
Can't locate object method "store_cdata" via package "XML::TreeBuilder" at /usr/share/perl5/vendor_perl/Publican/XmlClean.pm line 998, <FH> line 12.



Version-Release number of selected component (if applicable):
rpm -q perl-XML-TreeBuilder 
perl-XML-TreeBuilder-4.2-0.fc19.noarch

rpm -q publican
publican-3.2.1-0.fc19.noarch



How reproducible:


Steps to Reproduce:
1. yum update publican
2. create a book, try to build an existing book
3. publican fails due to treebuilder error

Actual results:


Expected results:


Additional info:
Comment 1 Andrew Ross 2013-09-25 23:08:19 EDT
Sorted thanks to help from the mighty jfearn.

Note You need to log in before you can comment on or make changes to this bug.