Bug 1012271 - php fopen fatal ssl error
php fopen fatal ssl error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 03:20 EDT by Markus Falb
Modified: 2013-12-03 04:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 04:41:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 39039 None None None Never

  None (edit)
Description Markus Falb 2013-09-26 03:20:43 EDT
Description of problem:



Version-Release number of selected component (if applicable):

php-5.1.6-40.el5_9

How reproducible:

Always

Steps to Reproduce:
 
<?php
 $handle = fopen("https://maps.google.com", "r");
 $contents = stream_get_contents($handle);
 fclose($handle);
?>

Actual results:

It fetches the page, but emits a warning:
Warning: stream_get_contents(): SSL: fatal protocol error in bla.php on line 3

Expected results:

It fetches the page without warning.

Additional info:

Maybe it is this bug
https://bugs.php.net/bug.php?id=39039
http://lxr.php.net/xref/PHP_5_2/NEWS
Comment 1 Joe Orton 2013-12-03 04:41:25 EST
This bug has been reviewed by Red Hat, and there are no plans to address it in Red Hat Enterprise Linux 5.  If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.  The issue is already fixed in RHEL-6.

Note You need to log in before you can comment on or make changes to this bug.