Bug 1012278 - [RHSC] The IP address of the RHSC management server in the browser address bar does not automatically navigate to the webadmin portal login page, and the page that is displayed has links to many resources that are not relevant to RHSC
[RHSC] The IP address of the RHSC management server in the browser address ba...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Shruti Sampat
: ZStream
: 1020193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 03:46 EDT by Shruti Sampat
Modified: 2016-04-18 06:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: cb13
Doc Type: Bug Fix
Doc Text:
Previously, links which are not relevant to Red Hat Storage Console were displayed in the Home page. Now, with this update, only the links which are relevant to Red Hat Storage Console are displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:44:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (144.48 KB, image/png)
2013-09-26 03:46 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21195 None None None Never

  None (edit)
Description Shruti Sampat 2013-09-26 03:46:37 EDT
Created attachment 803259 [details]
screenshot

Description of problem:
------------------------
With RHSC Big Bend, using the IP of the management server alone in the browser address bar used to navigate to the webadmin portal login page automatically.

With RHSC cb1, this is not the behavior. Instead, the page that is displayed, has links to the User Portal, Reports Portal and the webadmin portal. 

There is a link to the 'Console Client Resources' page on ovirt.org ( http://www.ovirt.org/Console_Client_Resources )

There are links to various documentation, all of which result in 'Page not found.'

There are other links like 'Getting Support' and 'RHEV Users Group' and 'Knowledge Base'

Find screenshot attached.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.1-0.0.1.master.el6ev 

How reproducible:
always

Steps to Reproduce:
1. Install RHSC and run the setup.
2. Use the IP of the management server in the address bar of the browser.

Actual results:
The page attached in the screenshot with the above described links is displayed.

Expected results:
Either redirect to webadmin portal or display a page with links relevant to RHSC.

Additional info:
Comment 2 Prasanth 2013-10-17 06:39:21 EDT
*** Bug 1020193 has been marked as a duplicate of this bug. ***
Comment 3 Shruti Sampat 2013-12-24 09:42:59 EST
Verified as fixed in Red Hat Storage Console 2.1.2-0.30.el6rhs 

The following links are now found on the welcome page - 

1. Administration Portal
2. Administration Guide
3. CLI Guide
4. Developer Guide
6. Installation Guide
7. Getting Support
8. RHS Users Group
9. Knowledge Base
Comment 4 Shalaka 2014-01-07 00:25:11 EST
Please review the edited DocText and signoff.
Comment 5 Kanagaraj 2014-01-16 01:41:35 EST
doc_text looks good.
Comment 7 errata-xmlrpc 2014-02-25 02:44:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.