Bug 101229 - can't find rpmlib, a dependency for glibc-common-2.2.5-43
can't find rpmlib, a dependency for glibc-common-2.2.5-43
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-30 07:16 EDT by Toni Willberg
Modified: 2016-11-24 10:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 07:20:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2003-07-30 07:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.8.0

Description of problem:
I'm upgrading a RH6.2 to 7.3 manually (don't ask why :)

Can't seem to install glibc-common because rpmlib is missing. There does not
seem to be anything providing rpmlib.

rpm -Uvh  pam-0.75-32.i386.rpm  passwd-0.67-1.i386.rpm db3-3.3.11-6.i386.rpm 
glib2-2.0.1-2.i386.rpm  libuser-0.50.2-1.i386.rpm  openssl-0.9.6b-32.7.i386.rpm
 bind-9.2.1-1.7x.2.i386.rpm  bind-utils-9.2.1-1.7x.2.i386.rpm 
cyrus-sasl-md5-1.5.24-25.i386.rpm  openldap-2.0.27-2.7.3.i386.rpm 
glibc-2.2.5-43.i386.rpm  rpm-4.0.4-7x.18.i386.rpm 
glibc-common-2.2.5-43.i386.rpm  perl-5.6.1-34.99.6.i386.rpm

error: failed dependencies:
  rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by glibc-common-2.2.5-43


Current versions are:
 glibc-2.1.3-29
 rpm-4.0.2-6x



Version-Release number of selected component (if applicable):
glibc-common-2.2.5-43

How reproducible:
Always
Comment 1 Jakub Jelinek 2003-07-30 07:20:29 EDT
Of course there is, rpm itself.
As it suggests, you need at least rpm 4.0.4 installed before you do the upgrade.
Comment 2 Toni Willberg 2003-07-30 07:38:14 EDT
Well, there is no way to install latest RedHat 7.3 Updates rpm before
glibc-common is installed. You know this.

Actually, I found a workaround solution:
http://www.google.fi/search?q=cache:Gxdg73Pg7hsJ:www.geocrawler.com/archives/3/87/2002/9/100/9592697/+rpmlib(PartialHardlinkSets)+redhat+7.3&hl=fi&ie=UTF-8

Basicly, one just needs to install an _unofficial_ rpm and popt from:
ftp://people.redhat.com/jbj/rpm-4.0.4-6x


And "Worksforme" is not the right answer for this kind of reports. Try to be
more polite towards other people next time, thank you.

Note You need to log in before you can comment on or make changes to this bug.