Bug 1012294 - csprocessor snapshot always uses strict validation
csprocessor snapshot always uses strict validation
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 04:41 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:14:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Lee Newson 2013-09-26 18:54:26 EDT
Making the first comment private because of internal links. Here is the content with the links removed:

[thildred@thildred csp]$ csprocessor snapshot 13109 --new
CSProcessor client version: 1.0.3
Loading configuration from /home/thildred/.config/csprocessor.ini
Connecting to PressGang server: <SNIP>

Creating the snapshot...
Saving to the server...
ERROR: Line 310: Invalid Chapter! The topic title doesn't match.
       -> Specified: Storage
       -> Topic 8671: Introduction to Storage in Red Hat Enterprise Virtualization
ERROR: Line 321: Invalid Section! The topic title doesn't match.
       -> Specified: Adding POSIX Compliant File System Storage
       -> Topic 10032: POSIX Compliant File System Storage in Red Hat Enterprise Virtualization
ERROR: Line 758: Invalid Section! The topic title doesn't match.
       -> Specified: Restoring Your Red Hat Enterprise Virtualization Manager to a New System from a Complete Backup
       -> Topic 21938: What is a complete backup of the Red Hat Enterprise Virtualization Manager?
ERROR: Line 764: Invalid Section! The topic title doesn't match.
       -> Specified: Restoring Your Red Hat Enterprise Virtualization Manager from an Incomplete Backup
       -> Topic 21944: What is an Incomplete Backup of the Red Hat Enterprise Virtualization Manager?
ERROR: The Content Specification is not valid.

The revision of the Content Specification is invalid and as such the snapshot couldn't be saved.
Comment 2 Lee Newson 2013-09-26 18:55:58 EDT
Secondly renaming this bug to be more accurate, as it's handling them just fine. The problem is that it's using strict processing and there's no way to turn it off.
Comment 3 Lee Newson 2013-09-26 21:55:48 EDT
Fixed in csprocessor 1.0.4.

This is from changing from strict to permissive processing. There was a field set that was setting processing to permissive, but when that field got changed the logic wasn't reversed so it's always processing it as strict. I've changed this now so that the processing will be permissive again.

Note You need to log in before you can comment on or make changes to this bug.