Bug 1012318 - Unable to define content-view filter rules
Unable to define content-view filter rules
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 05:24 EDT by Sachin Ghai
Modified: 2014-04-24 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Added package group filter (37.14 KB, image/png)
2013-10-18 10:03 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-09-26 05:24:34 EDT
Description of problem:
I was trying to define filter rules after associating content/repo with cv and created filter. But I couldn't see the 'Add new Rule' button.

Looks like again there is something missing. Earlier in nightlies, I saw 'Add' button for associating repo with filter  under 'Repositories' tab and now its missing there.

I opened a bz to confirm this change sometime back  (https://bugzilla.redhat.com/show_bug.cgi?id=1007290)


When you navigate 'Repositories' tab under filters, there is no 'Add' button visible. And I think this is the cause why I can't see the 'Add New Rule' button.

Version-Release number of selected component (if applicable):
katello-1.4.7-1.git.27.a8e92b3.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a CV definition
2. select CV --> contents--> associate any repo/product ( Notice Add button)
3. Create a filter
4. select the filter-> Go to 'Repositories' page and try to associate the repo (here  Add button is missing)
5. Then go to Rules tab to define new rule

Actual results:
Unable to define a filter rule as Add New Rule button is not available

Expected results:
Use should be able to define new rule after associating contents with cv and cv filter

Additional info:
Comment 3 Walden Raines 2013-09-26 11:58:55 EDT
PR:  https://github.com/Katello/katello/pull/3043
Comment 4 Walden Raines 2013-09-26 15:10:27 EDT
commit 8842d3937632c265d6fda1af41184a161d1c9243
Author: Walden Raines <walden@redhat.com>
Date:   Thu Sep 26 11:47:58 2013 -0400

    Bug #1012318 - ensure add button apppears for filters, fixes #3032.

commit a9c68abbc65a0250592ff64b7e91bd0960702336
Merge: b427988 bdbc286
Author: Walden Raines <walden@redhat.com>
Date:   Thu Sep 26 10:55:43 2013 -0700

    Merge pull request #3041 from waldenraines/bug-1012104
    
    Bug #1012104 - set width of container panel to 0px to avoid overlap.
Comment 7 Sachin Ghai 2013-10-18 10:02:17 EDT
Verified with snap6 compose2 (MDP2)


katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch


I can successfully define the filter rules.. And 'Add' button is there to associate repo to filters.
Comment 8 Sachin Ghai 2013-10-18 10:03:20 EDT
Created attachment 813787 [details]
Added package group filter
Comment 9 Bryan Kearney 2014-04-24 13:10:37 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 10 Bryan Kearney 2014-04-24 13:11:46 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.