Bug 1012367 - Deployment of Business-central to cluster fails on AppSetup.assertPlayground()
Deployment of Business-central to cluster fails on AppSetup.assertPlayground()
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 07:10 EDT by Radovan Synek
Modified: 2014-08-06 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
node one server log (184.11 KB, text/x-log)
2013-09-26 07:10 EDT, Radovan Synek
no flags Details
node two server log (239.32 KB, text/x-log)
2013-09-26 07:10 EDT, Radovan Synek
no flags Details
zookeeper log (29.65 KB, text/plain)
2013-09-26 07:11 EDT, Radovan Synek
no flags Details

  None (edit)
Description Radovan Synek 2013-09-26 07:10:13 EDT
Created attachment 803353 [details]
node one server log

Description of problem:
Deployment of Business central fails because of some missing file during application setup - see the attached server log for more details. Unfortunately it's hard to investigate further since the error stacktrace does not contain information about the missing file (because of missing call of super(params) in org.kie.commons.java.nio.file.FileSystemException).

Version-Release number of selected component (if applicable):
BPMS-6.0.0.ER3

How reproducible:
This is the difficult thing - this issue does not occur anytime

Steps to Reproduce:
1. setup the cluster - zookeeper, helix, EAP configuration with 2 nodes
2. start EAP in domain mode
3. deploy Business-Central and watch the server log - sometimes the error appears, sometimes not.

Additional information:
It seems the deployment of Business-central failed only on the first node, on the second node was successful - please take a look at both server logs.
Comment 1 Radovan Synek 2013-09-26 07:10:45 EDT
Created attachment 803354 [details]
node two server log
Comment 2 Radovan Synek 2013-09-26 07:11:35 EDT
Created attachment 803355 [details]
zookeeper log
Comment 4 Radovan Synek 2013-12-03 08:54:49 EST
The issue occurs no more with both empty and non-empty niogit.

Verified on BPMS-6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.