This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012434 - libiniconfig doesn't trim trailing whitespace
libiniconfig doesn't trim trailing whitespace
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ding-libs (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 09:15 EDT by Dmitri Pal
Modified: 2014-06-18 00:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: ding-libs-0.3.0.1-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:13:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dist-git patch (7.37 KB, patch)
2013-09-27 06:15 EDT, Jakub Hrozek
no flags Details | Diff

  None (edit)
Description Dmitri Pal 2013-09-26 09:15:43 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/sssd/ticket/2095

libiniconfig used to trim trailing whitespace of values, but recent versions stopped doing so. A config line like this:

"cache_credentials = true "

breaks sssd startup.
Comment 1 Jakub Hrozek 2013-09-27 04:54:41 EDT
To reproduce, add a line with trailing whitespace to the sssd.conf:

 "cache_credentials = true "

With the unpatched version, this breaks sssd startup, as the value is read by the sssd including the whitespace.
Comment 2 Jakub Hrozek 2013-09-27 06:15:24 EDT
Created attachment 803858 [details]
dist-git patch
Comment 4 Amith 2013-12-04 08:13:15 EST
Verified the bug on ding-libs version : ding-libs-0.3.0.1-20.el7

Steps followed during verification:

1. Installed older version of ding-libs (ding-libs-0.3.0.1-16.el7) and reproduced the bug. See the Error message of sssd service startup:

# systemctl start sssd.service
Job for sssd.service failed. See 'systemctl status sssd.service' and 'journalctl -xn' for details.
 
# systemctl status sssd.service
sssd.service - System Security Services Daemon
   Loaded: loaded (/usr/lib/systemd/system/sssd.service; disabled)
   Active: failed (Result: exit-code) since Wed 2013-12-04 18:33:10 IST; 12s ago
  Process: 4927 ExecStart=/usr/sbin/sssd -D -f (code=exited, status=4)

Dec 04 18:33:09 rhel-7.redhat.com systemd[1]: Starting System Security Services Daemon...
Dec 04 18:33:10 rhel-7.redhat.com systemd[1]: sssd.service: control process exited, code=exited status=4
Dec 04 18:33:10 rhel-7.redhat.com systemd[1]: Failed to start System Security Services Daemon.
Dec 04 18:33:10 rhel-7.redhat.com systemd[1]: Unit sssd.service entered failed state.

2. Upgraded the ding-libs package to latest version and SSSD service starts fine.

# systemctl status sssd.service
sssd.service - System Security Services Daemon
   Loaded: loaded (/usr/lib/systemd/system/sssd.service; disabled)
   Active: active (running) since Wed 2013-12-04 18:37:22 IST; 3s ago
  Process: 4996 ExecStart=/usr/sbin/sssd -D -f (code=exited, status=0/SUCCESS)
 Main PID: 4997 (sssd)
   CGroup: /system.slice/sssd.service
           ├─4997 /usr/sbin/sssd -D -f
           ├─4998 /usr/libexec/sssd/sssd_be --domain LDAP --debug-to-files
           ├─4999 /usr/libexec/sssd/sssd_nss --debug-to-files
           └─5000 /usr/libexec/sssd/sssd_pam --debug-to-files
Comment 5 Ludek Smid 2014-06-13 08:13:23 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.