Bug 1012456 - apache-commons-daemon-1.0.15-4.fc21 is FTBFS
apache-commons-daemon-1.0.15-4.fc21 is FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apache-commons-daemon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 09:46 EDT by Dan Horák
Modified: 2013-10-29 05:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.0.15-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 05:33:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-09-26 09:46:12 EDT
I had to re-add the patch that adds s390x and ppc64 support into apache-commons-daemon as the apsupport.m4 file updated by DAEMON-289 is not present in 1.0.15. The subsequent build in rawhide failed with

...
[INFO] 
[INFO] --- maven-surefire-plugin:2.16:test (default-test) @ commons-daemon ---
[INFO] 
[INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ commons-daemon ---
[INFO] Building jar: /builddir/build/BUILD/commons-daemon-1.0.15-src/target/commons-daemon-1.0.15.jar
[INFO] 
[INFO] --- maven-site-plugin:3.3:attach-descriptor (attach-descriptor) @ commons-daemon ---
[WARNING] Failed to resolve artifact: org.apache.maven.shared:maven-shared-components:pom:16
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Skipping Commons Daemon
[INFO] This project has been banned from the build due to previous failures.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 6.232s
[INFO] Finished at: Thu Sep 26 13:19:25 UTC 2013
[INFO] Final Memory: 35M/270M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.3:attach-descriptor (attach-descriptor) on project commons-daemon: Execution attach-descriptor of goal org.apache.maven.plugins:maven-site-plugin:3.3:attach-descriptor failed: Plugin org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies could not be resolved: Failed to collect dependencies at org.apache.maven.plugins:maven-site-plugin:jar:3.3 -> org.apache.maven.doxia:doxia-integration-tools:jar:1.5: Failed to read artifact descriptor for org.apache.maven.doxia:doxia-integration-tools:jar:1.5: Cannot access central (http://repo.maven.apache.org/maven2) in offline mode and the artifact org.apache.maven.shared:maven-shared-components:pom:16 has not been downloaded from it before. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.dVFsd2 (%build)
    Bad exit status from /var/tmp/rpm-tmp.dVFsd2 (%build)


for full logs please see
http://koji.fedoraproject.org/koji/taskinfo?taskID=5986980

Version-Release number of selected component (if applicable):
apache-commons-daemon-1.0.15-4.fc21
Comment 1 Michal Srb 2013-09-27 04:31:28 EDT
Could you please try to rebuild your package again? I think the problem should be fixed now.
Comment 2 Dan Horák 2013-09-27 04:53:32 EDT
no change if I see correctly - http://koji.fedoraproject.org/koji/taskinfo?taskID=5990144

BTW maven-shared is not used in the buildroot, if the fix should be there
Comment 3 Mikolaj Izdebski 2013-10-29 05:33:25 EDT
Fixed in apache-commons-daemon-1.0.15-4
Comment 4 Mikolaj Izdebski 2013-10-29 05:33:40 EDT
I believe that this bug is fixed in apache-commons-daemon-1.0.15-4,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=467402

Note You need to log in before you can comment on or make changes to this bug.