Bug 1012487 - Missing debug informations for installer thread
Missing debug informations for installer thread
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 10:41 EDT by Fabian Deutsch
Modified: 2014-01-21 14:50 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
The installer thread could hardly be debugged because in some cases no backtrace was getting logged. Now a traceback is logged to help debugging.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:50:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached the screenshort for ovirt-node.log.png (19.24 KB, image/png)
2014-01-07 01:37 EST, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19317 None None None Never

  None (edit)
Description Fabian Deutsch 2013-09-26 10:41:12 EDT
Description of problem:
Currently the installer thread can hardly be debugged because in som cases no backtrace is getting logged.
Comment 1 Fabian Deutsch 2013-09-26 10:41:47 EDT
Fixed in ec012817a93406373720b990edde299db51dd6f0
Comment 3 Mike Burns 2013-09-26 16:12:26 EDT
(In reply to Fabian Deutsch from comment #1)
> Fixed in ec012817a93406373720b990edde299db51dd6f0

Is there a gerrit reference for this commit?  I'm not seeing it.
Comment 8 Cheryn Tan 2013-11-07 19:36:42 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 haiyang,dong 2014-01-07 01:37:34 EST
Created attachment 846473 [details]
attached the screenshort for ovirt-node.log.png

Test version:
rhevh-6.5-20131220.0
ovirt-node-3.0.1-13.el6_5.noarch

Now traceback info was logged in /var/log/ovirt-node.log when an exception was thrown for installer thread(Seen log info in ovirt-node.log.png),this could help us debug issue.

So this bug has been fixed, change the status into "verified".
Comment 11 errata-xmlrpc 2014-01-21 14:50:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.