Bug 1012496 - Capturing stderr during transactions leads to an exception
Capturing stderr during transactions leads to an exception
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 10:49 EDT by Fabian Deutsch
Modified: 2014-01-21 14:50 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:50:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19319 None None None Never

  None (edit)
Description Fabian Deutsch 2013-09-26 10:49:12 EDT
Description of problem:
A use before assignment leads to a exception when something is written to stderr during a transaction.
Comment 1 Fabian Deutsch 2013-09-26 10:49:40 EDT
Fixed in upstream 8d8c9dc09ce4bd3ffc89537d9d1f0e570d41aab7
Comment 3 Mike Burns 2013-09-26 16:14:25 EDT
Is there a gerrit reference?  I don't see this commit.
Comment 7 Cheryn Tan 2013-11-07 19:32:33 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 Charlie 2013-11-27 22:05:51 EST
Hi there, just after a bit more information, as to whether this needs doc text, and if so what was causing this problem, and what the fix is.

Thanks.
Comment 9 Fabian Deutsch 2013-11-29 04:34:56 EST
Hey Charlie,

no we don't need a technote here. That's mainly backend stuff.
Comment 10 haiyang,dong 2014-01-07 02:01:40 EST
Hey Fabian,
Not sure how to verify this bug, could you help this or i just need to check patch was merged into rhevh 6.5 base image.
Comment 11 Fabian Deutsch 2014-01-14 06:08:49 EST
Hey Haiyang,

you can check this as follows:
1. Set netconsole host which is not reachable
2. Save page

Result:
No exception should be shown on the screen.
Comment 12 haiyang,dong 2014-01-15 00:37:24 EST
Test version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch

Test as follow:
1. Set netconsole host which is not reachable
2. Save page

Test result:
No exception was shown on the screen when set netconsole with a unreachable server

so this bug has been fixed, change the status into "verified".
Comment 14 errata-xmlrpc 2014-01-21 14:50:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.