Bug 1012543 - business-central.war does not deploy correctly on JDK 7 1.7.0_40
business-central.war does not deploy correctly on JDK 7 1.7.0_40
Status: CLOSED DUPLICATE of bug 1007425
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mauricio Salatino
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 11:34 EDT by Bernard Tison
Modified: 2014-03-19 06:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 11:46:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Tison 2013-09-26 11:34:22 EDT
Description of problem:
BPMS 6 deployed on EAP 6.1 does not start up correctly on JDK 1.7.0_40 and later (tested on Fedora 19)

Version-Release number of selected component (if applicable):
BPMS6 ER3

How reproducible:
Always

Steps to Reproduce:
1. Install a Fedora 19 machine with Java JDK 7, version > 1.7.0_40
2. Install BPMS6 ER3 on top of EAP 6.1 
3. Start up the server (bin/standalone.sh)

Actual results:

business-central.war is not deployed correctly.

Stacktrace:

17:23:48,052 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."business-central.war".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."business-central.war".WeldStartService: Failed to start service
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_40]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_40]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]
Caused by: org.jboss.weld.exceptions.UnproxyableResolutionException: WELD-001437 Normal scoped bean class java.util.Hashtable is not proxyable because the type is final or it contains a final method final boolean java.util.Hashtable.initHashSeedAsNeeded(int) - Managed Bean [class org.jbpm.formModeler.core.processing.formProcessing.FunctionsProvider] with qualifiers [@Any @Default].
	at org.jboss.weld.util.Proxies.getUnproxyableClassException(Proxies.java:229)
	at org.jboss.weld.util.Proxies.getUnproxyableTypeException(Proxies.java:184)
	at org.jboss.weld.util.Proxies.getUnproxyableTypesExceptionInt(Proxies.java:195)
	at org.jboss.weld.util.Proxies.getUnproxyableTypesException(Proxies.java:169)
	at org.jboss.weld.bootstrap.Validator.validateBean(Validator.java:147)
	at org.jboss.weld.bootstrap.Validator.validateRIBean(Validator.java:163)
	at org.jboss.weld.bootstrap.Validator.validateBeans(Validator.java:382)
	at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:367)
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	... 3 more



Expected results:
Correct deployment

Additional info:
Same exception on JDK 1.7.0_60 (latest on fedora 19)
Comment 2 Bernard Tison 2013-09-26 11:46:57 EDT

*** This bug has been marked as a duplicate of bug 1007425 ***

Note You need to log in before you can comment on or make changes to this bug.