This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012580 - hard-coded log file path
hard-coded log file path
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: unspecified (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: kconner
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 12:36 EDT by Viet Nguyen
Modified: 2013-10-14 12:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 12:02:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viet Nguyen 2013-09-26 12:36:10 EDT
Description of problem:

server.log on start up:

Caused by: java.io.FileNotFoundException: /home/rnc/ER3-switchyardrtgovclient/jboss-eap-6.1/standalone/log/server.log (No such file or directory)


Full stacktrace
---
java.lang.IllegalArgumentException: Failed to instantiate class "org.jboss.logmanager.handlers.PeriodicRotatingFileHandler" for handler "FILE"
at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:118)
at org.jboss.logmanager.config.LogContextConfigurationImpl.doPrepare(LogContextConfigurationImpl.java:333)
at org.jboss.logmanager.config.LogContextConfigurationImpl.prepare(LogContextConfigurationImpl.java:290)
at org.jboss.logmanager.config.LogContextConfigurationImpl.commit(LogContextConfigurationImpl.java:299)
at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:505)
at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:96)
at org.jboss.as.logging.logmanager.ConfigurationPersistence.configure(ConfigurationPersistence.java:128)
at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:300)
at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:262)
at java.util.logging.LogManager$2.run(LogManager.java:278)
at java.security.AccessController.doPrivileged(Native Method)
at java.util.logging.LogManager.readPrimordialConfiguration(LogManager.java:276)
at java.util.logging.LogManager.getLogManager(LogManager.java:259)
at java.util.logging.Logger.<init>(Logger.java:245)
at java.util.logging.LogManager$RootLogger.<init>(LogManager.java:1106)
at java.util.logging.LogManager$RootLogger.<init>(LogManager.java:1103)
at java.util.logging.LogManager$1.run(LogManager.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.util.logging.LogManager.<clinit>(LogManager.java:176)
at org.jboss.modules.Main.main(Main.java:394)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:116)
... 19 more
Caused by: java.io.FileNotFoundException: /home/rnc/ER3-switchyardrtgovclient/jboss-eap-6.1/standalone/log/server.log (No such file or directory)
at java.io.FileOutputStream.openAppend(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:207)
at org.jboss.logmanager.handlers.FileHandler.setFile(FileHandler.java:154)
at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.setFile(PeriodicRotatingFileHandler.java:105)
at org.jboss.logmanager.handlers.FileHandler.setFileName(FileHandler.java:192)
at org.jboss.logmanager.handlers.FileHandler.<init>(FileHandler.java:122)
at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.<init>(PeriodicRotati


Version-Release number of selected component (if applicable):
ER3

How reproducible:
100%
Comment 2 Len DiMaggio 2013-09-30 09:30:38 EDT
Viet - the only way that you would see this issue is if you installed FSW6 ER3 from the .zip file - did you do this?

We are only supporting installing from the installer jar for beta.
Comment 3 Viet Nguyen 2013-09-30 13:54:17 EDT
I only saw this from .zip file install.  No error seen with installer.

Note You need to log in before you can comment on or make changes to this bug.