Bug 1012676 - Allow additional URI parameters for Camel bindings
Allow additional URI parameters for Camel bindings
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: 6.0.0
Assigned To: Rob Cernich
Tomas Rohovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 16:54 EDT by Keith Babo
Modified: 2016-01-04 00:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1600 Major Closed Add non-model URI configuration parameters to all integrated SY gateways 2017-02-01 10:21 EST
JBoss Issue Tracker SWITCHYARD-1747 Major Closed Add non-model URI configuration parameters to all camel EMF models 2017-02-01 10:21 EST

  None (edit)
Description Keith Babo 2013-09-26 16:54:03 EDT
At present, the user is limited to the parameters contained in the SwitchYard Camel component schema when configuring Camel gateways.  Since many Camel gateways have additional parameters which are not part of the schema, we need a way to allow these parameters to augment the existing configuration for a binding.
Comment 1 JBoss JIRA Server 2013-10-01 09:14:48 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1600

pushed
Comment 2 JBoss JIRA Server 2013-10-01 13:26:31 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1600

Do I need to create a tooling-specific JIRA for this issue?
Comment 3 JBoss JIRA Server 2013-10-04 13:49:58 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1747

pushed
Comment 7 JBoss JIRA Server 2014-06-16 19:48:16 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1747 to Closed
Comment 8 JBoss JIRA Server 2014-06-16 19:49:53 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1600 to Closed

Note You need to log in before you can comment on or make changes to this bug.