Bug 1012698 - valgrind on ARM finds numerous glibc errors
valgrind on ARM finds numerous glibc errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
rawhide
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark Wielaard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-26 18:49 EDT by Jerry James
Modified: 2013-11-04 16:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 16:53:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failed stp build on ARM koji (247.16 KB, text/x-log)
2013-09-26 18:49 EDT, Jerry James
no flags Details

  None (edit)
Description Jerry James 2013-09-26 18:49:44 EDT
Created attachment 803631 [details]
Failed stp build on ARM koji

Description of problem:
I thought we had the stp build fixed with the recent valgrind change, but, alas!  That fixed the build on i686 and x86_64 only.  Now the ARM build is failing, with a long list of errors found inside glibc routines.  Since the koji build logs will eventually disappear, I am attaching the entire build log to this bug report.

See http://koji.fedoraproject.org/koji/taskinfo?taskID=5989445 for as long as that URL is good.

Version-Release number of selected component (if applicable):
valgrind-3.8.1-30.fc21.armv7hl

How reproducible:
Always

Steps to Reproduce:
1. fedpkg clone stp
2. cd stp
3. fedpkg srpm
4. Build the source RPM on ARM

Actual results:
The attached build log shows the stp build failing its tests due to errors reported by valgrind inside glibc routines.

Expected results:
No errors (unless there really is an stp bug on ARM, of course).

Additional info:
Comment 1 Mark Wielaard 2013-09-27 04:10:36 EDT
Was there ever a successful build on arm before? I cannot quickly find one in koji and the old arm.koji doesn't seem to use valgrind?

Analysing this might take some time. valgrind ARM support is less mature than other arches. But a lot of ARM work has been done for the upcoming 3.9.0 version.
Comment 2 Jerry James 2013-10-08 23:23:41 EDT
You're right.  We weren't doing arm builds before F-20, so this is new.  I have disabled the valgrind tests on arm for now.  I will try them again once in awhile after I see a valgrind update to see if they can be re-enabled.  Thanks again.
Comment 3 Mark Wielaard 2013-10-09 07:37:40 EDT
I did some scratch builds against current upstream valgrind svn:
http://kojipkgs.fedoraproject.org//work/tasks/3197/6013197/

Results also posted upstream here:
http://thread.gmane.org/gmane.comp.debugging.valgrind.devel/24561/focus=24621
Comment 4 Jerry James 2013-10-09 10:17:31 EDT
Thanks for the pointers.  I'll follow the upstream discussion.
Comment 5 Mark Wielaard 2013-11-04 05:27:20 EST
valgrind 3.9.0 is now in updates-testing for f20 and in rawhide. Would you be able to test against that version?
https://admin.fedoraproject.org/updates/FEDORA-2013-20461/valgrind-3.9.0-1.fc20
Comment 6 Jerry James 2013-11-04 16:48:57 EST
Hey, nice, that solves the problem.  Valgrind is now silent except for when there's an actual problem in the stp code.  Thanks a ton, Mark.
Comment 7 Mark Wielaard 2013-11-04 16:53:18 EST
Thanks for checking.

Note You need to log in before you can comment on or make changes to this bug.