Bug 1012734 - ordermgmt/app demo does not work
ordermgmt/app demo does not work
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Nick Cross
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 00:16 EDT by Jiri Pechanec
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-09-27 00:16:16 EDT
The ordermgmt/app cannot be executed. The are at least two issues
1) The pom files disable tests. OrderClient is in test directory so when a user runs mvn exec:java then he gets CNFE
2) If manually overriden and tests are built then there are missing dependencies as there is another CNFE

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.codehaus.mojo.exec.ExecJavaMojo$1.run(ExecJavaMojo.java:297)
        at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.NoClassDefFoundError: org/switchyard/component/test/mixins/http/HTTPMixIn
        at org.overlord.rtgov.quickstarts.demos.orders.OrdersClient.main(OrdersClient.java:51)
        ... 6 more
Caused by: java.lang.ClassNotFoundException: org.switchyard.component.test.mixins.http.HTTPMixIn
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 7 more
Comment 1 Jiri Pechanec 2013-09-27 01:03:59 EDT
This issue blocks almost all RTGov QS
Comment 2 Gary Brown 2013-09-27 04:40:36 EDT
The test client runs as expected in the rtgov product branch. So I believe this is as a result of the productisation changes - possibly tests are normally disabled by default, and therefore the supporting switchyard test classes were not included in the list of dependencies.

Reassigning to prod team.
Comment 3 Nick Cross 2013-09-30 12:45:09 EDT
Should be fixed in the next ER4. Tests are no longer disabled
Comment 6 Jiri Pechanec 2013-10-08 03:45:21 EDT
Verified in ER4 04-Oct-2013 04:44

Note You need to log in before you can comment on or make changes to this bug.