Bug 1012738 - Installer allows to install RTGov server ithout FSW [NEEDINFO]
Installer allows to install RTGov server ithout FSW
Status: CLOSED WORKSFORME
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: ---
Assigned To: Gary Brown
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 00:32 EDT by Jiri Pechanec
Modified: 2013-10-31 12:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 12:24:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gbrown: needinfo? (jpechane)


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-09-27 00:32:12 EDT
FSW is hard pre-requisite for RTGov server, yet installer allows user to install it without FSW
Comment 1 Francisco Canas 2013-09-27 15:14:54 EDT
Added to core-packs spec so user can no longer install RTGov-s without FSW selected.

See commit for details:
http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=2aa7c34cad3823a8830a00982c5ff355557513ed
Comment 2 Thomas Hauser 2013-09-27 16:36:34 EDT
Jiri:
From our spec document: https://docspace.corp.redhat.com/docs/DOC-147383

Selecting Serviceworks will also select RT-Gov Client, unless RT-Gov Server is also selected. 
Deselecting RT-Gov Server will also select RT-Gov Client if Serviceworks is currently selected.

Both of these lines imply that it is possible to have RTGov server selected without Serviceworks being selected. If this is incorrect, the spec will need updating and we'd need a discussion relating to this.
Comment 3 Jiri Pechanec 2013-09-30 01:24:13 EDT
I've found this issue because I had RTGov server installed without FSW and there were missing dependencies - like Google ProtoBuf. So let's have PM/dev decide what is the bug - if the standalone or missing dependencies
Comment 4 Gary Brown 2013-10-10 12:15:01 EDT
Could not reproduce this with ER4. Could you try again, and if problem still present, provide the steps to reproduce. I started up the server with no problem, and then reported some activities via the REST API.

Note You need to log in before you can comment on or make changes to this bug.