Bug 1012755 - drupal commands can not be executed in drupal app home dir after migration
drupal commands can not be executed in drupal app home dir after migration
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 01:37 EDT by Yan Du
Modified: 2015-05-14 19:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 12:36:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-09-27 01:37:56 EDT
Description of problem:
drupal commands can not be executed in drupal app home dir after migration

[drupal-dy.int.rhcloud.com 523e9c606cec0e1fe9000021]\> drush core-status
 PHP executable        :  /usr/bin/php                                                       
 PHP configuration     :  /var/lib/openshift/523e9c606cec0e1fe9000021/php/configuration/etc/ 
                          php.ini                                                            
 PHP OS                :  Linux                                                              
 Drush version         :  6.0                                                                
 Drush configuration   :                                                                     
 Drush alias files     :

    
                                                                 
Version-Release number of selected component (if applicable):
INT(devenv_3835)


How reproducible:
Always


Steps to Reproduce:

1. Create a drupal-quickstart app
#rhc app create cdrupal php-5.3 mysql-5.1 cron --from-code=git://github.com/openshift/drupal-quickstart.git --no-git
2. Do upgrade and migrate
3. SSH into this app and come into the home dir
#rhc ssh cdrupal
#cd ~
4. Run some drupal commands and check drush environment status
#drush core-status



Actual results:

[drupal-dy.int.rhcloud.com 523e9c606cec0e1fe9000021]\> drush core-status
 PHP executable        :  /usr/bin/php                                                       
 PHP configuration     :  /var/lib/openshift/523e9c606cec0e1fe9000021/php/configuration/etc/ 
                          php.ini                                                            
 PHP OS                :  Linux                                                              
 Drush version         :  6.0                                                                
 Drush configuration   :                                                                     
 Drush alias files     :  


 
Expected results:

drush command should execute normally in home dir
#drush core-status
 Drupal version         :  7.23                                                              
 Site URI               :  http://default                                                    
 Database driver        :  mysql                                                             
 Database username      :  adminetqKtmz                                                      
 Database name          :  drupal                                                            
 Database               :  Connected                                                         
 Drupal bootstrap       :  Successful                                                        
 Drupal user            :  Anonymous                                                         
 Default theme          :  bartik                                                            
 Administration theme   :  seven                                                             
 PHP executable         :  /usr/bin/php                                                      
 PHP configuration      :  /var/lib/openshift/523e9c606cec0e1fe9000021/php/configuration/etc 
                           /php.ini                                                          
 PHP OS                 :  Linux                                                             
 Drush version          :  6.0                                                               
 Drush configuration    :                                                                    
 Drush alias files      :                                                                    
 Drupal root            :  /var/lib/openshift/523e9c606cec0e1fe9000021/app-root/data/downloa 
                           ds/drupal-7.23                                                    
 Site path              :  sites/default                                                     
 File directory path    :  sites/default/files                                               
 Private file           :  /var/lib/openshift/523e9c606cec0e1fe9000021/app-root/data/private 
 directory path            /                                                                 
 Temporary file         :  /tmp/drupal/                                                      
 directory path



Additional info:

create a new drupal on INT, and "drush core-status" can be executed normally in app home dir.
Comment 1 Vojtech Vitek 2013-09-30 16:03:09 EDT
@Yan Du, does it happen only with the apps that were created against old Drupal Quickstart code, right?

If that's correct, this is expected behavior. Users are advised to run the following command themselves:

cat >$OPENSHIFT_HOMEDIR/.drush/drushrc.php <<EOF
<?php
  \$options['uri'] = \$_ENV['OPENSHIFT_APP_DNS'];
  \$options['root'] = \$_ENV['OPENSHIFT_REPO_DIR'].'php';
EOF


Can you test against the latest Drupal Quickstart code?
1. Create new Drupal Quickstart app
2. Migrate
3. drush works even in homedir
Comment 2 Yan Du 2013-10-09 04:49:08 EDT
Hi, Vojtech Vitek

the drupal app was created on 22 Sep, should I do a round migration test to the latest devenv, or just upgrade to devenv_stage_488?
Comment 3 Xiaoli Tian 2013-10-09 06:16:40 EDT
(In reply to Yan Du from comment #2)
> Hi, Vojtech Vitek
> 
> the drupal app was created on 22 Sep, should I do a round migration test to
> the latest devenv, or just upgrade to devenv_stage_488?

Check your existing prepared drupal app on  INT or upgrade to devenv-stage_488 if you are going to check if it's still reproducible.
Comment 4 Yan Du 2013-10-09 07:01:22 EDT
do migration test with new drupal app  (devenv_stage_486 -> devenv_stage_488)

issue can't be reproduced. drush command works normally in app home dir after migration.
Comment 5 Vojtech Vitek 2013-10-31 13:52:07 EDT
Sorry for not answering sooner, I just got back from my PTO. Comment 4 sounds to me like we can close this bz, right?
Comment 6 Yan Du 2013-11-13 05:22:42 EST
@Vojtech Vitek

Yes, Test on INT(devenv_4026), it works now. Seems it caused by old drupal quickstart code, issue can't be reproduced for the new one. 

Thanks.

Note You need to log in before you can comment on or make changes to this bug.