Bug 1012762 - RFE: Add a legend for any highlighting
RFE: Add a legend for any highlighting
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 01:48 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-09-27 01:48:59 EDT
Highlighting done in the xml and content spec editors should be described with a legend.
Comment 1 Matthew Casperson 2013-11-17 19:21:55 EST
Fixed in 201311181014

This can be verified on the dev server.
Comment 2 Lee Newson 2013-11-17 22:23:43 EST
Verified that the legend is displayed at the bottom of the page for regular topics and Content Specifications. The legend however is missing on the Translated Topic view (this might be intentional).

I also think that this information should be that is displayed via a switch and in a pop-up. An example would be having a "Legend" button somewhere on the screen, then when clicking the button it pops up and shows the highlighting legend (or displays it somehow on the screen). The reason for this is it clogs up the screen and makes it look too busy in my opinion. Doing something like this would also allow for a lot more expansion if needed, because at the moment you are limited to about 8-10 different colours (also if you are working with a small screen the legend gets cut off).
Comment 3 Lee Newson 2013-11-18 00:13:24 EST
Oops made a massive error in that last comment. The first sentence of the second paragraph should have been:

"I also think that this information should be displayed via a switch and then shown in a pop-up."
Comment 4 Matthew Casperson 2013-11-18 19:39:42 EST
The spell checking should actually be disabled in the translated topics views. This is a bug, because people can change the xml using the spelling suggestions. But I'll add a legend for the other highlights.
Comment 5 Matthew Casperson 2013-11-18 19:55:44 EST
Fixed in 201311191047

The help overlay does (or should) have the legend information, so this information is already available in a popup.

I have added the ability to show or hide the legend. In this case we could then add two rows of legend boxes (if we ever got to that point), and users can disable it if they take up too much room or look too cluttered.

This can be verified on the dev server.
Comment 6 Lee Newson 2013-11-18 20:20:18 EST
Works for me on all three views now and the hide/show legend works without any issues in Chrome 28 and Firefox.

I do wonder if perhaps the legend should be on the right side with the help button just so it's all grouped together, but it works nicely now so marking this as VERIFIED.
Comment 7 Lee Newson 2013-11-18 20:21:00 EST
Firefox 22*
Comment 8 Matthew Casperson 2013-11-18 23:08:24 EST
As a side note, the spell checking context menu in translated topics doesn't not actually modify the text.

Note You need to log in before you can comment on or make changes to this bug.