Bug 1012772 - skipped count is not available in XML output of rebalance status
skipped count is not available in XML output of rebalance status
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 1010204
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 02:19 EDT by Aravinda VK
Modified: 2014-04-17 09:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1010204
Environment:
Last Closed: 2014-04-17 09:14:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-27 03:11:03 EDT
REVIEW: http://review.gluster.org/6000 (cli: skipped tag in xml output of rebalance/remove-brick status) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Anand Avati 2013-09-27 06:22:54 EDT
REVIEW: http://review.gluster.org/6000 (cli: skipped tag in xml output of rebalance/remove-brick status) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Anand Avati 2013-09-30 05:35:23 EDT
REVIEW: http://review.gluster.org/6000 (cli: skipped tag in xml output of rebalance/remove-brick status) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 4 Anand Avati 2013-09-30 07:44:16 EDT
REVIEW: http://review.gluster.org/6000 (cli: skipped tag in xml output of rebalance/remove-brick status) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 5 Anand Avati 2013-10-04 00:12:27 EDT
COMMIT: http://review.gluster.org/6000 committed in master by Anand Avati (avati@redhat.com) 
------
commit 59b4e379e6d56af4828738c966b80c313415f632
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Sep 25 12:04:11 2013 +0530

    cli: skipped tag in xml output of rebalance/remove-brick status
    
    Skipped files count is available in CLI output of rebalance status
    and remove-brick status, but not available in xml output.
    
    Example output:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volRebalance>
        <op>3</op>
        <nodeCount>1</nodeCount>
        <node>
          <nodeName>localhost</nodeName>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <status>0</status>
          <statusStr>completed</statusStr>
        </node>
        <aggregate>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <status>0</status>
          <statusStr>completed</statusStr>
        </aggregate>
      </volRebalance>
    </cliOutput>
    
    BUG: 1012772
    Change-Id: I05191293403e66e0d681f0cd0422aa3c78a2d91d
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/6000
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2013-10-22 04:41:31 EDT
REVIEW: http://review.gluster.org/6119 (cli: skipped tag in xml output of rebalance/remove-brick status) posted (#1) for review on release-3.4 by Aravinda VK (avishwan@redhat.com)
Comment 7 Anand Avati 2013-10-24 08:20:48 EDT
COMMIT: http://review.gluster.org/6119 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 71614ecbd96f65273d7a19bc62b1d918a8b36191
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Oct 22 14:09:44 2013 +0530

    cli: skipped tag in xml output of rebalance/remove-brick status
    
    Skipped files count is available in CLI output of rebalance status
    and remove-brick status, but not available in xml output.
    
    Example output:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
      <volRebalance>
        <op>3</op>
        <nodeCount>1</nodeCount>
        <node>
          <nodeName>localhost</nodeName>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <status>0</status>
          <statusStr>completed</statusStr>
        </node>
        <aggregate>
          <files>0</files>
          <size>0</size>
          <lookups>0</lookups>
          <failures>0</failures>
          <skipped>0</skipped>
          <status>0</status>
          <statusStr>completed</statusStr>
        </aggregate>
      </volRebalance>
    </cliOutput>
    
    BUG: 1012772
    Change-Id: I4f5128c3fa3b2b791bcbaf41ac7f229f80bfefe9
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/6000
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/6119
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 09:14:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.