Bug 1012777 - user system_u does not exist
user system_u does not exist
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
: 1012924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 02:32 EDT by Heiko Adams
Modified: 2013-10-09 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: libsemanage-2.1.10-12.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:11:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2013-09-27 02:32:30 EDT
Description of problem:
During the update of the latest selinux policy the following messages are raised
libsemanage.semanage_seuser_set_sename: SELinux user system_u does not exist (No such file or directory).
libsemanage.seuser_parse: could not parse seuser record (Invalid argument).
libsemanage.dbase_file_cache: could not cache file database (Invalid argument).
libsemanage.semanage_base_merge_components: could not merge local modifications into policy (Invalid argument).

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.12.1-83.fc20.noarch

How reproducible:
allways

Steps to Reproduce:
1. Install the latest update
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Grepl 2013-09-27 03:25:47 EDT
Fixed in libsemanage-2.1.10-12.fc20
Comment 2 Fedora Update System 2013-09-27 03:27:06 EDT
libsemanage-2.1.10-12.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-17505/libsemanage-2.1.10-12.fc20
Comment 3 Miroslav Grepl 2013-09-27 07:45:25 EDT
*** Bug 1012924 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2013-09-27 20:07:13 EDT
Package libsemanage-2.1.10-12.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libsemanage-2.1.10-12.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17505/libsemanage-2.1.10-12.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-09 10:11:44 EDT
libsemanage-2.1.10-12.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.