Bug 101279 - libaio doesn't build
Summary: libaio doesn't build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: libaio   
(Show other bugs)
Version: beta1
Hardware: s390
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 16:16 UTC by Elliot Lee
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 11:59:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Lee 2003-07-30 16:16:59 UTC
Probably gcc 3.3... In any case, the symptom is:

io_getevents.c:25: error: asm-specifier for variable `__arg`' conflicts with asm clobber list

According to Jakub, the problem is that syscall-s390.h is totally broken and needs 
revamping. He suggesting using the INTERNAL_SYSCALL macro from 
glibc/sysdeps/unix/sysv/linux/s390/s390-*/sysdep.h and related files.

Comment 1 Phil Knirsch 2003-09-24 11:46:48 UTC
Builds fine on latest tree Taroon-re0922.nightly

Read ya, Phil

Comment 2 Elliot Lee 2003-09-24 11:58:05 UTC
Red Hat Linux aka Cambridge, not RHEL aka Taroon.

Comment 3 Elliot Lee 2003-09-24 11:59:10 UTC
It passes there too, never mind.


Note You need to log in before you can comment on or make changes to this bug.