Bug 101279 - libaio doesn't build
libaio doesn't build
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: libaio (Show other bugs)
beta1
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-30 12:16 EDT by Elliot Lee
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 07:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2003-07-30 12:16:59 EDT
Probably gcc 3.3... In any case, the symptom is:

io_getevents.c:25: error: asm-specifier for variable `__arg`' conflicts with asm clobber list

According to Jakub, the problem is that syscall-s390.h is totally broken and needs 
revamping. He suggesting using the INTERNAL_SYSCALL macro from 
glibc/sysdeps/unix/sysv/linux/s390/s390-*/sysdep.h and related files.
Comment 1 Phil Knirsch 2003-09-24 07:46:48 EDT
Builds fine on latest tree Taroon-re0922.nightly

Read ya, Phil
Comment 2 Elliot Lee 2003-09-24 07:58:05 EDT
Red Hat Linux aka Cambridge, not RHEL aka Taroon.
Comment 3 Elliot Lee 2003-09-24 07:59:10 EDT
It passes there too, never mind.

Note You need to log in before you can comment on or make changes to this bug.