Bug 1012807 - Met 'gear postreceive' error when creating drupal application.
Met 'gear postreceive' error when creating drupal application.
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates (Show other bugs)
2.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 03:54 EDT by Yujie Zhang
Modified: 2017-05-31 14:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broker log (12.68 KB, text/plain)
2013-09-27 03:55 EDT, Yujie Zhang
no flags Details
broker_log_on_puddle-2-1-2014-03-21 (27.18 KB, text/plain)
2014-03-24 01:07 EDT, Tian Feng
no flags Details

  None (edit)
Description Yujie Zhang 2013-09-27 03:54:28 EDT
Description of problem:

Tried to create drupal application from website and rhc, met the following error:

[root@dhcp-8-252 Downloads]# rhc app create drupalexample2 php-5.3 mysql-5.1 --from-code https://github.com/openshift/drupal-quickstart.git 
Please sign in to start a new session to 10.4.59.157.
Password: ******
Server does not support environment variables.

Application Options
-------------------
  Namespace:   domain
  Cartridges:  php-5.3, mysql-5.1
  Source Code: https://github.com/openshift/drupal-quickstart.git
  Gear Size:   default
  Scaling:     no

Creating application 'drupalexample2' ... 
The initial build for the application failed. Last 10 kB of build output:
Syntax error on line 2 of
/var/lib/openshift/5244fedbaeb9058bec000029/php/configuration/etc/conf.d/openshift.conf:
DocumentRoot must be a directory
httpd (no pid file) not running
Checking pear: pear.drush.org/drush

Attempting to discover channel "pear.drush.org"...
downloading channel.xml ...
Starting to download channel.xml (804 bytes)
....done: 804 bytes
Auto-discovered channel "pear.drush.org", alias "drush", adding to registry
downloading drush-6.0.0.tgz ...
Starting to download drush-6.0.0.tgz (508,464 bytes)
...done: 508,464 bytes
install ok: channel://pear.drush.org/drush-6.0.0

/var/lib/openshift/5244fedbaeb9058bec000029/app-root/runtime/repo/.openshift/action_hooks/build:
line 24: /var/lib/openshift/5244fedbaeb9058bec000029//.drush/drushrc.php: No
such file or directory
An error occurred executing 'gear postreceive'

For more details about the problem, try running the command again with the
'--trace' option.


Version-Release number of selected component (if applicable):
OSE-1.2.3

How reproducible:
always

Steps to Reproduce:
1.Create drupal application from website using the following url:
https://<server>/app/console/application_types/custom?cartridges[]=php-5.3&cartridges[]=mysql-5.1&initial_git_url=https://github.com/openshift/drupal-quickstart
2. Create drupal appliction using rhc command:

rhc app create drupalexample2 php-5.3 mysql-5.1 --from-code https://github.com/openshift/drupal-quickstart.git 

3.

Actual results:

Failed to create and met 'gear postreceive' error. Broker log is as attchment.
Borker mcollective log:
<--snip-->
E, [2013-09-26T22:41:50.499963 #1507] ERROR -- : openshift.rb:170:in `rescue in with_container_from_args' CLIENT_ERROR: The initial build for the application failed. Last 10 kB of build output:
CLIENT_MESSAGE: Stopping Apache+mod_php HTTPD server
CLIENT_ERROR: Syntax error on line 2 of /var/lib/openshift/524519dfaeb9050905000001/php/configuration/etc/conf.d/openshift.conf:
CLIENT_ERROR: DocumentRoot must be a directory
CLIENT_ERROR: httpd (no pid file) not running
CLIENT_ERROR: Checking pear: pear.drush.org/drush
CLIENT_ERROR:
CLIENT_ERROR: Attempting to discover channel "pear.drush.org"...
CLIENT_ERROR: downloading channel.xml ...
CLIENT_ERROR: Starting to download channel.xml (804 bytes)
CLIENT_ERROR: ....done: 804 bytes
CLIENT_ERROR: Auto-discovered channel "pear.drush.org", alias "drush", adding to registry
CLIENT_ERROR: downloading drush-6.0.0.tgz ...
CLIENT_ERROR: Starting to download drush-6.0.0.tgz (508,464 bytes)
CLIENT_ERROR: ...done: 508,464 bytes
CLIENT_ERROR: install ok: channel://pear.drush.org/drush-6.0.0
CLIENT_ERROR:
CLIENT_ERROR: /var/lib/openshift/524519dfaeb9050905000001/app-root/runtime/repo/.openshift/action_hooks/build: line 24: /var/lib/openshift/524519dfaeb9050905000001//.drush/drushrc.php: No such file or directory
CLIENT_ERROR: An error occurred executing 'gear postreceive'
CLIENT_ERROR:
CLIENT_ERROR: For more details about the problem, try running the command again with the '--trace' option.
<--snip-->


Expected results:

The drupal application should be created successfully. 

Additional info:

This issue does NOT happen against online.
Dig more about this issue, this is introduced by the following two commits.
https://github.com/openshift/drupal-quickstart/commit/dc0c5dce490df71e423b4c992f2c6aca2a66f430
https://github.com/openshift/drupal-quickstart/commit/7adb3cab2a548040f78160ef08ced3f14c82bc54
This two commit is working well with online env, but not with ose env.
Comment 1 Yujie Zhang 2013-09-27 03:55:41 EDT
Created attachment 803807 [details]
broker log
Comment 5 Tian Feng 2014-03-24 01:05:49 EDT
Test on puddle-2-1-2014-03-21.
Still the error and can't enable PHP extension for drupal quickstart. Full log can be accessed in attachment.

<--------broker log--------->
WD php: Exception: PHP extensions: Disabled                              [error]

Drupal requires you to enable the PHP extensions in the following
list (see the system requirements page for more information):dom
gd
 in install_verify_requirements() (line 768 of
/var/lib/openshift/532fbac2cfb77fd0df000040/app-root/data/downloads/drupal-7.26/includes/install.core.inc).
WD php: Warning: Cannot modify header information - headers already    [warning]
sent by (output started at
/var/lib/openshift/532fbac2cfb77fd0df000040/app-root/runtime/dependencies/php/phplib/pear/pear/php/drush/includes/output.inc:38)
in drupal_send_headers() (line 1217 of
/var/lib/openshift/532fbac2cfb77fd0df000040/app-root/data/downloads/drupal-7.26/includes/bootstrap.inc).
Exception: PHP extensions: Disabled

Drupal requires you to enable the PHP extensions in the following list (see the <a href="http://drupal.org/requirements">system requirements page</a> for more information):<div class="item-list"><ul><li class="first">dom</li>
<li class="last">gd</li>
</ul></div> in install_verify_requirements() (line 768 of /var/lib/openshift/532fbac2cfb77fd0df000040/app-root/data/downloads/drupal-7.26/includes/install.core.inc).
Drush command terminated abnormally due to an unrecoverable error.       [error]
Unable to configure your Drupal installation

-------------------------
Git Post-Receive Result: failure
Activation status: failure
Activation failed for the following gears:
532fbac2cfb77fd0df000040 (Error activating gear: CLIENT_ERROR: Failed to execute action hook 'deploy' for 532fbac2cfb77fd0df000040 application drupalexample2)
Deployment completed with status: failure
postreceive failed (pid:14196)
Comment 6 Tian Feng 2014-03-24 01:07:51 EDT
Created attachment 877935 [details]
broker_log_on_puddle-2-1-2014-03-21
Comment 7 Tian Feng 2014-03-24 01:41:29 EDT
Pls ignore comment5 and comment6. Use wrong option to create drupal application.

Successfully create drupal app on puddle-2-1-2014-03-21. So verify this bug. Thanks!

$ rhc app create drupalexample2 php-5.3 mysql-5.1 --from-code https://github.com/openshift/drupal-quickstart.git  -g medium
Application Options
-------------------
Domain:      lala
Cartridges:  php-5.3, mysql-5.1
Source Code: https://github.com/openshift/drupal-quickstart.git
Gear Size:   medium
Scaling:     no

Creating application 'drupalexample2' ... 
It appears you have a deplist.txt and .openshift/pear.txt file.
Please consider running `git rm deplist.txt'.
done

  MySQL 5.1 database added.  Please make note of these credentials:

       Root User: adminRgmVSVi
   Root Password: DvujKfKlvqgN
   Database Name: drupalexample2

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

Waiting for your DNS name to be available ... done

Cloning to 'drupalexample2'...
The authenticity of host 'drupalexample2-lala.ose-201403214.com.cn (10.66.78.214)' can't be established.
RSA key fingerprint is f6:6f:57:6e:55:5c:fe:1c:ff:05:57:c5:ba:b1:a7:31.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'drupalexample2-lala.ose-201403214.com.cn,10.66.78.214' (RSA) to the list of known hosts.

Your application 'drupalexample2' is now available.

  URL:        http://drupalexample2-lala.ose-201403214.com.cn/
  SSH to:     532fc477cfb77fe10000000f@drupalexample2-lala.ose-201403214.com.cn
  Git remote: ssh://532fc477cfb77fe10000000f@drupalexample2-lala.ose-201403214.com.cn/~/git/drupalexample2.git/
  Cloned to:  /home/violet/drupalexample2

Run 'rhc show-app drupalexample2' for more details about your app.
Comment 8 Johnny Liu 2014-03-24 02:16:28 EDT
For ose-2.1, drupal quick-start app should be deployed onto node that optional metapackage is already installed. So in comment 7, we specified medium gear size to make it is deployed onto optional node.
Comment 10 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.