Bug 1012841 - [User Portal] Opening RDP console causes popup: Error: Access is denied
[User Portal] Opening RDP console causes popup: Error: Access is denied
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Andrew Dahms
Lucy Bopf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 05:01 EDT by Jiri Belka
Modified: 2014-09-18 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-18 21:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ie screenshot (97.05 KB, image/png)
2013-09-27 05:01 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-09-27 05:01:45 EDT
Created attachment 803827 [details]
ie screenshot

Description of problem:
Opening RDP console causes popup: Error: Access is denied. It does not appear if the domain is added into Trusted Sites. Thus maybe this could be added to documentation if there would be no other solutions.

Version-Release number of selected component (if applicable):
is16

How reproducible:
100%

Steps to Reproduce:
1. clean (really clean) IE, be sure there is not addon present even not loaded for your site, see 'All add-ons'
2. open rdp console
3.

Actual results:
ie popup with error but after clicking 'OK' one can proceed

Expected results:
?

Additional info:
Comment 1 Jiri Belka 2013-09-27 05:04:03 EDT
This issue was already describe as part of another issue - BZ984977. But BZ984977 did not propose any solution to this error popup.
Comment 2 Michal Skrivanek 2013-10-02 09:40:32 EDT
right, so instead of NOTABUG in bug 984977 what do you suggest? I'd think WONTFIX...
is there anything about this in docs? If not it might be worth a note in "known issues"
Comment 3 Jiri Belka 2013-10-02 10:09:52 EDT
Not really about RDP, I think it could be made more clear.

"Confirm a security exception for the website or add the website to your browser's list of trusted sites, and your web browser displays the login screen.

...

Add the URL for the Red Hat Enterprise Virtualization Manager to your list of trusted sites. If Red Hat Enterprise Virtualization Manager is not in the list of trusted sites of Internet Explorer 8 and Internet Explorer 9, the SPICE Client window changes from full-screen to windowed-screen. If Red Hat Enterprise Virtualization Manager is a T rusted Site, a full-screen SPICE window remains open."
Comment 4 Michal Skrivanek 2013-10-04 05:46:24 EDT
can we please tweak the current doc so it doesn't sound SPICE specific? It is needed for RDP and probably something more, so I wouldn't put a finite list
Comment 5 Andrew Dahms 2014-05-06 07:32:57 EDT
Hi Jiri, Michal,

Thank you for raising this bug and for providing information about the circumstances under which this error appears.

I will investigate the issue on my end and see if I can replicate the root cause and whether or not we can add something in the documentation to cover this.

Michal, is there a specific section of the documentation you had in mind?

Kind regards,

Andrew
Comment 6 Michal Skrivanek 2014-05-06 07:51:17 EDT
not sure of all the places, but the User Guide "4.1. Introduction to Connection Protocols" looks suitable to me.
Thanks!
Comment 7 Andrew Dahms 2014-07-08 20:06:29 EDT
Fixed in 8702, 30847.
Comment 8 Andrew Dahms 2014-08-18 07:00:14 EDT
Documentation Link
------------------------------
http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5-Beta/html-single/User_Guide/index.html#sect-Logging_in_for_the_First_Time_Installing_the_Engine_Certificate

What Changed
------------------------------
The following topic was revised as outlined below:

Installing the Red Hat Enterprise Virtualization Manager Certificate in Firefox [8702-638680]

Converted this topic into a proper procedure for importing the Manager certificate in Firefox.

The following topic was added to outline how to perform the sam procedure in Internet Explorer:

Installing the Red Hat Enterprise Virtualization Manager Certificate in Internet Explorer [30847]

Updated the revision history: [34617-687367]

NVR
------------------------------
Red_Hat_Enterprise_Virtualization-User_Guide-3.5-Beta-en-US-3.5-6

Moving to ON_QA.
Comment 9 Lucy Bopf 2014-08-31 20:49:09 EDT
Peer reviewed.

The revised and new topics now clearly outline step-by-step procedures for importing the Manager certificate in Firefox and Internet Explorer.
(These changes are also live in the 3.4 documentation.)

VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.