Bug 1012875 - Error while subscribing via activation key
Error while subscribing via activation key
Status: CLOSED DUPLICATE of bug 1015944
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 06:05 EDT by Hayk Hovsepyan
Modified: 2013-10-07 16:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 16:39:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-09-27 06:05:56 EDT
Description of problem:
When registering client via activation key which contains content view and RHEL repo pool, gives error.
"subscription-manager register  --org testorg --activationkey testkey" has out:
"undefined method `provider' for nil:NilClass".


Version-Release number of selected component (if applicable):
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-postgresql-1.3.0-6.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
katello-configure-foreman-proxy-1.4.5-8.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.14.alpha.el6sat.noarch
signo-katello-0.0.20-3.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-configure-foreman-1.4.5-8.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.4-2.el6sat.noarch
signo-0.0.20-3.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-9.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
candlepin-cert-consumer-apollo.usersys.redhat.com-1.0-1.noarch
foreman-1.3.0-6.el6sat.noarch
katello-cli-1.4.3-15.el6sat.noarch
katello-configure-1.4.5-8.el6sat.noarch
pulp-selinux-2.3.0-0.14.alpha.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.14.alpha.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.14.alpha.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.6-13.el6sat.noarch
katello-glue-pulp-1.4.6-13.el6sat.noarch
katello-glue-candlepin-1.4.6-13.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
katello-all-1.4.6-13.el6sat.noarch
foreman-proxy-1.3.0-1.el6sat.noarch
katello-cli-common-1.4.3-15.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-server-2.3.0-0.14.alpha.el6sat.noarch
pulp-nodes-common-2.3.0-0.14.alpha.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
katello-glue-elasticsearch-1.4.6-13.el6sat.noarch
katello-1.4.6-13.el6sat.noarch
candlepin-0.8.25-1.el6sam.noarch
katello-foreman-all-1.4.6-13.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.14.alpha.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

How reproducible:
always

Steps to Reproduce:
1. Import valid manifest. Enable repo set and repo "Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server "
2. Create content definition, add that repo into it, publish, and promote to "test" environment.
3. Create activation key with promoted content view and add RHEL repo pool into key.
4. Subscribe client via activation key. It will show error: "undefined method `provider' for nil:NilClass".

Actual results:
error is shown

Expected results:
it should register successfully

Additional info:
when activation key does not contain resource pool, it works fine.
Comment 3 Mike McCune 2013-10-07 16:39:07 EDT

*** This bug has been marked as a duplicate of bug 1015944 ***

Note You need to log in before you can comment on or make changes to this bug.