This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 101290 - [AIO] lockup on hammer
[AIO] lockup on hammer
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brian Brock
:
: 103240 (view as bug list)
Depends On:
Blocks: 97942
  Show dependency treegraph
 
Reported: 2003-07-30 13:06 EDT by Jakub Jelinek
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 09:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelinek 2003-07-30 13:06:25 EDT
Description of problem:
It seems hammer kernels lock up when doing make check in rtkaio.
Reproduced twice on thor and once on romaine. Does not seem to lock up on other arches.
Version-Release number of selected component (if applicable):


How reproducible:
rpmbuild --rebuild ~jakub/glibc-2.3.2-66.src.rpm
Comment 1 Jakub Jelinek 2003-07-30 13:07:22 EDT
Oops, sorry.
Comment 2 Elliot Lee 2003-07-30 13:13:36 EDT
The call trace was inside __wtd_down_failed inside generic_aio_rw inside 
generic_aio_complete_write

The kernel is 2.4.21-1.1931.2.342.entsmp
Comment 4 Jim Paradis 2003-08-27 23:16:23 EDT
*** Bug 103240 has been marked as a duplicate of this bug. ***
Comment 5 John W. Lockhart 2003-08-27 23:34:38 EDT
Takes about 5 minutes to reproduce using the aiotest
in Bug 103240, which also has a full console capture.

Comment 7 Jeffrey Moyer 2003-09-02 09:23:07 EDT
The arguments to wtd_down_common were swapped, causing the kernel to try to lock
something that wasn't a lock.  Fix is in latest taroon.
Comment 8 Jay Turner 2003-09-03 09:02:49 EDT
Fix confirmed on Melody box in lab running 2.4.21-1.1931.2.421.ent.

Note You need to log in before you can comment on or make changes to this bug.