Bug 1012941 - hwcert server start/status has lmbench and httpd errors
hwcert server start/status has lmbench and httpd errors
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1012943
  Show dependency treegraph
 
Reported: 2013-09-27 08:27 EDT by Greg Nichols
Modified: 2013-11-13 04:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1012943 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:58:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network test patch setting serverMode False, and using "service" for httpd (1.50 KB, patch)
2013-09-27 10:09 EDT, Greg Nichols
no flags Details | Diff
network test patch enabling serverMode only on EthernetTest. (1.64 KB, patch)
2013-09-27 10:10 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-09-27 08:27:08 EDT
Description of problem:

When starting the hwcert server, errors are reported such as:

10GigEthernet test server start:
Warning: SELinux is in enforcing mode - it must be set to "permissive" for certification testing.
Starting lmbench services...bind: Address already in use
 done.
Error: could not start httpd
"systemctl start httpd.service" has output on stderr

These errors are due to the new speed-specific network test, each of which are trying to start services repeatedly.

These errors do not affect the support hwcert-client testing.


Version-Release number of selected component (if applicable):

hwcert-server 1.6.5 R14
Comment 1 Greg Nichols 2013-09-27 10:07:04 EDT
also, systemctl is being used for httpd - it should use "service".
Comment 2 Greg Nichols 2013-09-27 10:09:43 EDT
Created attachment 803971 [details]
network test patch setting serverMode False, and using "service" for httpd
Comment 3 Greg Nichols 2013-09-27 10:10:34 EDT
Created attachment 803972 [details]
network test patch enabling serverMode only on EthernetTest.
Comment 6 Brian Brock 2013-10-08 11:13:00 EDT
fix verified in hwcert-client-1.6.5-21.el6
Comment 8 errata-xmlrpc 2013-11-13 04:58:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.