Bug 1012943 - hwcert server start/status has lmbench and httpd errors
hwcert server start/status has lmbench and httpd errors
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Pavel Stehlik
:
Depends On: 1012941
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 08:28 EDT by Greg Nichols
Modified: 2015-07-13 09:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: hwcert-client 1.7.0-58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1012941
Environment:
Last Closed: 2015-07-13 09:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network test patch setting serverMode False (612 bytes, patch)
2013-09-27 10:19 EDT, Greg Nichols
no flags Details | Diff
network test patch enabling serverMode only on EthernetTest. (1.64 KB, patch)
2013-09-27 10:19 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-09-27 08:28:00 EDT
+++ This bug was initially created as a clone of Bug #1012941 +++

Description of problem:

When starting the hwcert server, errors are reported such as:

10GigEthernet test server start:
Warning: SELinux is in enforcing mode - it must be set to "permissive" for certification testing.
Starting lmbench services...bind: Address already in use
 done.
Error: could not start httpd
"systemctl start httpd.service" has output on stderr

These errors are due to the new speed-specific network test, each of which are trying to start services repeatedly.

These errors do not affect the support hwcert-client testing.


Version-Release number of selected component (if applicable):

hwcert-server 1.6.5 R14
Comment 1 Greg Nichols 2013-09-27 10:19:06 EDT
Created attachment 803977 [details]
network test patch setting serverMode False
Comment 2 Greg Nichols 2013-09-27 10:19:32 EDT
Created attachment 803978 [details]
network test patch enabling serverMode only on EthernetTest.
Comment 5 Petr Beňas 2013-10-22 11:29:31 EDT
Reproduced in hwcert-server-1.7.0-57.el7.noarch and verified in hwcert-server-1.7.0-58.el7.noarch.
Comment 8 brose 2015-07-13 09:57:29 EDT
Closing as hwcert-client is obsolete.
Please use redhat-certification-hardware instead.

Note You need to log in before you can comment on or make changes to this bug.