Bug 1012947 - nfs+afr+logging: "unlock failed on 1 unlock" seems meaningless
nfs+afr+logging: "unlock failed on 1 unlock" seems meaningless
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
pre-release
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Anuradha
: ZStream
: 1012945 (view as bug list)
Depends On: 989362
Blocks: 1012945
  Show dependency treegraph
 
Reported: 2013-09-27 08:31 EDT by Anuradha
Modified: 2016-09-19 22:00 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989362
Environment:
Last Closed: 2014-04-17 07:48:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-27 08:38:05 EDT
REVIEW: http://review.gluster.org/6012 (Logging :  "unlock failed on 1 unlock" seems meaningless) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 2 Anuradha 2013-09-27 08:41:45 EDT
*** Bug 1012945 has been marked as a duplicate of this bug. ***
Comment 3 Anand Avati 2013-09-30 02:55:34 EDT
REVIEW: http://review.gluster.org/6012 (Logging :  Improved the log message on unlock failure in afr_unlock_inodelk_cbk.) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 4 Anand Avati 2013-09-30 15:55:03 EDT
COMMIT: http://review.gluster.org/6012 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2526eea5dde0aa1af6ff43cf63f6e818798c8f2f
Author: Anuradha <atalur@redhat.com>
Date:   Fri Sep 27 17:42:17 2013 +0530

    Logging :  Improved the log message on unlock failure in afr_unlock_inodelk_cbk.
    
    "unlock failed on 1 unlock" seems meaningless in the log message. Improved it.
    
    Change-Id: If67d3f9d4aa5310d0b6728a6c89fa58a5cc93d12
    BUG: 1012947
    Signed-off-by: Anuradha <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6012
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Niels de Vos 2014-04-17 07:48:57 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.