Bug 1012957 - Regression: Can't boot a guest with snapshot=on
Regression: Can't boot a guest with snapshot=on
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 08:53 EDT by CongLi
Modified: 2014-06-17 23:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:32:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongLi 2013-09-27 08:53:45 EDT
Description of problem:
Can't boot a guest with snapshot=on

Version-Release number of selected component (if applicable):
kernel-3.10.0-23.el7.x86_64
qemu-kvm-1.5.3-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot a Win2003 guest w/ snapshot=on
/usr/libexec/qemu-kvm \
-drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2003-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,snapshot=on,cache=unsafe,format=qcow2,aio=native \
-device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \

2.
3.

Actual results:
Guest can't boot up w/ error:
qemu-kvm: -drive file=/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2003-32-virtio.qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,snapshot=on,cache=unsafe,format=qcow2,aio=native: Can't use snapshot=on with driver-specific options

Expected results:
Guest boot up successfully

Additional info:
1. qemu-kvm-1.5.3-3.el7.x86_64 works for me
Comment 3 Kevin Wolf 2013-11-12 04:08:18 EST
This should be fixed by the patches for bug 1026524 in qemu-kvm-1.5.3-16.el7.
Comment 4 CongLi 2013-11-14 21:38:03 EST
This bug is not existed on version: qemu-kvm-1.5.3-19.el7.x86_64 .

# /usr/libexec/qemu-kvm -drive file='/home/win2003-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,snapshot=on,cache=unsafe,format=qcow2,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 
VNC server running on `::1:5900'
Comment 5 Miya Chen 2013-11-14 22:15:41 EST
set verified according to commnet#4.
Comment 7 Ludek Smid 2014-06-13 05:32:35 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.