Bug 1012962 - Win2003 guest error when format disk
Win2003 guest error when format disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 09:02 EDT by CongLi
Modified: 2014-11-09 04:02 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-09 04:02:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest session log (2.24 KB, text/x-log)
2013-09-27 09:02 EDT, CongLi
no flags Details
format_disk log (630.00 KB, application/x-tar)
2013-12-03 01:21 EST, CongLi
no flags Details
screenshot of the test result (35.77 KB, image/png)
2014-11-05 21:36 EST, CongLi
no flags Details

  None (edit)
Description CongLi 2013-09-27 09:02:20 EDT
Created attachment 803958 [details]
guest session log

Description of problem:
Win2003 virtio-blk guest error when format disk

Version-Release number of selected component (if applicable):
kernel-3.10.0-23.el7.x86_64
qemu-kvm-1.5.3-7.el7.x86_64

How reproducible:
5/5

Steps to Reproduce:
1. Boot up a Win2003 guest w/ virtio_blk

2. echo list disk >  cmd && echo exit >>  cmd && diskpart /s cmd

3. echo %errorlevel%

4. echo select disk 1 > cmd && echo create partition primary >> cmd && echo select partition 1 >> cmd && echo assign letter=I >> cmd && echo exit >> cmd && diskpart /s cmd

5. echo %errorlevel%

Actual results:
step 4 error:
2013-09-26 18:23:55: C:\Documents and Settings\Administrator>
2013-09-26 18:23:55: echo select disk 1 > cmd && echo create partition primary >> cmd && echo select partition 1 >> cmd && echo assign letter=I >> cmd && echo exit >> cmd && diskpart /s cmd
2013-09-26 18:23:55: 
2013-09-26 18:23:55: Microsoft DiskPart version 5.2.3790.3959
2013-09-26 18:23:55: Copyright (C) 1999-2001 Microsoft Corporation.
2013-09-26 18:23:55: On computer: AUTOTEST-9D963B
2013-09-26 18:23:55: 
2013-09-26 18:23:55: Disk 1 is now the selected disk.
2013-09-26 18:26:55: 
2013-09-26 18:26:55: The disk management services could not complete the operation.
2013-09-26 18:26:55: 
2013-09-26 18:26:55: C:\Documents and Settings\Administrator>
2013-09-26 18:26:56: echo %errorlevel%
2013-09-26 18:26:56: 4

Expected results:
No error occur when format disk

Additional info:
1. Qemu CML:
/root/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130926-095954-7KTBxGqC,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130926-095954-7KTBxGqC,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130926-095954-7KTBxGqC,path=/tmp/seabios-20130926-095954-7KTBxGqC,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130926-095954-7KTBxGqC,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2003-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/storage.qcow2',index=2,if=none,id=drive-virtio-disk2,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x6,drive=drive-virtio-disk2,bootindex=1 \
    -device virtio-net-pci,netdev=idHZ8uB1,mac='9a:c6:c7:c8:c9:ca',bus=pci.0,addr=0x3,id='id2llSmw' \
    -netdev tap,id=idHZ8uB1,vhost=on,vhostfd=22,fd=21 \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'SandyBridge' \
    -M pc \
    -drive file='/root/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -spice port=3000,password=123456,addr=0,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4 \
    -vga qxl \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm

2. Cpuinfo:
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Xeon(R) CPU E31225 @ 3.10GHz
stepping	: 7
microcode	: 0x29
cpu MHz		: 1984.000
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 6
initial apicid	: 6
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6185.59
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
Comment 3 CongLi 2013-09-28 04:45:02 EDT
virtio-win version:
virtio-win-prewhql-0.1-71
Comment 15 CongLi 2013-12-03 01:21:31 EST
Created attachment 831887 [details]
format_disk log
Comment 17 Ronen Hod 2014-01-02 05:55:54 EST
Since it is 2003 and probably not a regression, deferring to 7.1.
Anyhow, happens with IDE too. not a virtio-win issue.
Comment 19 Vadim Rozenfeld 2014-11-03 04:47:42 EST
Does it still happen on rhel7.1 host?
Thanks,
Vadim.
Comment 20 CongLi 2014-11-05 21:33:39 EST
Can not reproduce this bug on the following versions:

kernel-3.10.0-196.el7.x86_64
qemu-kvm-rhev-2.1.2-5.el7.x86_64

steps:
1. Boot up a Win2003 guest w/ virtio_blk

2. echo list disk >  cmd && echo exit >>  cmd && diskpart /s cmd
Microsoft DiskPart version 5.2.3790.3959
Copyright (C) 1999-2001 Microsoft Corporation.
On computer: AUTOTEST-3D0064
 
Disk ###  Status      Size     Free     Dyn  Gpt
--------  ----------  -------  -------  ---  ---
Disk 0    Online        30 GB  8033 KB
Disk 1    Online      1020 MB  1020 MB

Leaving DiskPart... 

3. echo %errorlevel%
0

4. echo select disk 1 > cmd && echo create partition primary >> cmd && echo select partition 1 >> cmd && echo assign letter=I >> cmd && echo exit >> cmd && diskpart /s cmd

Microsoft DiskPart version 5.2.3790.3959
Copyright (C) 1999-2001 Microsoft Corporation.
On computer: AUTOTEST-3D0064
 
Disk 1 is now the selected disk.

Diskpart succeeded in creating the specified partition.

Partition 1 is now the selected partition.

Diskpart successfully assigned the driver letter or mount point.

Leaving Diskpart...

5. echo %errorlevel%
0

The screenshot of the test result attached.

Thanks.
Comment 21 CongLi 2014-11-05 21:36:14 EST
Created attachment 954258 [details]
screenshot of the test result
Comment 22 Vadim Rozenfeld 2014-11-06 03:33:30 EST
(In reply to CongLi from comment #21)
> Created attachment 954258 [details]
> screenshot of the test result

Many thanks, for re-testing it again.

Vadim.
Comment 23 Vadim Rozenfeld 2014-11-06 03:35:08 EST
Ronen, let's close this issue?

Vadim.

Note You need to log in before you can comment on or make changes to this bug.