Bug 1012966 - hwcert-backend save error saving from files stored on local hwcert-server
hwcert-backend save error saving from files stored on local hwcert-server
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1012967
  Show dependency treegraph
 
Reported: 2013-09-27 09:13 EDT by Greg Nichols
Modified: 2013-11-13 04:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1012967 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:58:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backend patch to correctly specify destination directory on server (1.22 KB, patch)
2013-09-27 09:29 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-09-27 09:13:48 EDT
Description of problem:

When the "hwcert-backend save" command is used to save files from the local wb store (/var/www/hwcert/store) to another server, the server reports an error page:

IOError: [Errno 2] No such file or directory: '/var/www/www/hwcert/store/Intel Corporation/S2600CP/S2600CP/x86_64/RHEL/7/hwcert-results-intel-canoepass-01.lab.eng.rdu.redhat.com-20130923141207.xml.gz'


Version-Release number of selected component (if applicable):

hwcert-client 1.6.5 R14
Comment 1 Greg Nichols 2013-09-27 09:29:35 EDT
Created attachment 803967 [details]
backend patch to correctly specify destination directory on server
Comment 6 Brian Brock 2013-10-08 12:37:19 EDT
Marking as verified in -21.el6, working as designed. 

It's clear enough, and any more potential problems should really be a separate bug given the explanation.
Comment 8 errata-xmlrpc 2013-11-13 04:58:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.