Bug 101299 - octave help system does not work
Summary: octave help system does not work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: octave   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 18:00 UTC by petrosyan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-01 21:37:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description petrosyan 2003-07-30 18:00:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
octave help system does not work

Version-Release number of selected component (if applicable):
octave-2.1.49-4

How reproducible:
Always

Steps to Reproduce:
1. run octave
2. type: help sin
you get: warning: help: Texinfo formatting filter exited abnormally
warning: help: raw Texinfo source of help text follows...
and then you get unintelligeble raw texinfo documentation.

3. type: help -i sin
you get:
info: /usr/local/info/octave.info: No such file or directory
help: sorry, `sin' is not indexed in the manual

octave info files are in /usr/share/info/ and not in /usr/local/info/

Comment 1 Lon Hohberger 2003-07-30 21:47:53 UTC
Packages addressing this problem are available from:

http://people.redhat.com/lhh/octave-2.1.50-2.i386.rpm
http://people.redhat.com/lhh/octave-2.1.50-2.src.rpm

And will appear in rawhide soon.

Comment 2 Lon Hohberger 2003-07-30 21:49:30 UTC
(Updating time-spent)

Comment 3 petrosyan 2003-07-31 03:00:44 UTC
octave-2.1.50-2.i386.rpm gives the following error:

octave:2> help -i sin
info: /usr/info/octave.info: No such file or directory
help: sorry, `sin' is not indexed in the manual

Comment 4 Lon Hohberger 2003-08-04 21:38:19 UTC
Ok, I actually tested and verified both cases this time ;)

Packages addressing this problem are available from:

http://people.redhat.com/lhh/octave-2.1.50-3.i386.rpm
http://people.redhat.com/lhh/octave-2.1.50-3.src.rpm

And will appear in rawhide soon.

Comment 5 petrosyan 2003-08-07 02:12:05 UTC
octave-2.1.50-3
"help -i sin" works now. but "help sin" still does not work properly:
octave:1> help sin
sin is a built-in mapper function
 
warning: help: Texinfo formatting filter exited abnormally
warning: help: raw Texinfo source of help text follows...
 
-*- texinfo -*-
@deftypefn {Mapping Function} {} sin (@var{x})
Compute the sin of each element of @var{x}.
@end deftypefn
 
........


Comment 6 Lon Hohberger 2003-09-23 19:53:32 UTC
Unfortunately, I couldn't reproduce this on 9, Severn, or Taroon...  What
version of info are you running?



Comment 7 petrosyan 2003-09-23 21:54:54 UTC
$ rpm -q info octave
info-4.5-2
octave-2.1.50-3

---------------------------------
$ octave
GNU Octave, version 2.1.50 (i686-pc-linux-gnu).
Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003 John W. Eaton.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTIBILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.
                                                                                
Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html
                                                                                
Report bugs to <bug-octave@bevo.che.wisc.edu>.
                                                                                
octave:1> help sin
sin is a built-in mapper function
                                                                                
warning: help: Texinfo formatting filter exited abnormally
warning: help: raw Texinfo source of help text follows...
                                                                                
-*- texinfo -*-
@deftypefn {Mapping Function} {} sin (@var{x})
Compute the sin of each element of @var{x}.
@end deftypefn
 
Additional help for built-in functions, operators, and variables
is available in the on-line version of the manual.  Use the command
`help -i <topic>' to search the manual index.
 
Help and information about Octave is also available on the WWW
at http://www.octave.org and via the help-octave@bevo.che.wisc.edu
mailing list.
octave:2>

Comment 8 petrosyan 2003-09-23 21:56:01 UTC
help -i sin

works correctly


Comment 9 petrosyan 2003-09-26 07:46:04 UTC
I have found what the problem is:

octave rpm does not depend on texinfo rpm, but it need texinfo rpm for its
online help system.

In 'Personal Desktop' installation mode texinfo rpm did not get installed and
octave was giving errors while formatting its online system.

octave should require texinfo rpm in its dependencies

Comment 10 Lon Hohberger 2003-09-26 13:16:31 UTC
Ah! Makes sense; I was wondering why I couldn't get it to fail - yet you
couldn't get it to work... ;)

Comment 11 Lon Hohberger 2003-09-26 19:30:17 UTC
That's the correct solution.  Building packages.

Comment 12 Lon Hohberger 2003-09-29 15:19:59 UTC
Added texinfo to "Requires" field.

Packages addressing this problem are available from:

http://people.redhat.com/lhh/octave-2.1.50-7.i386.rpm
http://people.redhat.com/lhh/octave-2.1.50-7.src.rpm

These will appear in rawhide soon.

Comment 13 Lon Hohberger 2003-10-01 21:37:41 UTC
Re-closing due to bugzilla outage earlier today.


Note You need to log in before you can comment on or make changes to this bug.