Bug 1012995 - Diagram export to a file should be fitted to the size of the process
Diagram export to a file should be fitted to the size of the process
Status: CLOSED WONTFIX
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Eclipse Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Robert (Bob) Brodt
Jozef Marko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 10:38 EDT by Jiri Svitak
Modified: 2015-12-07 13:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 13:24:10 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ParallelGateway.png (14.68 KB, image/png)
2013-10-09 08:32 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-09-27 10:38:36 EDT
Diagram export to a file should be fitted to the size of the process. Now it exports the whole canvas. Each time the user has to crop the image later. See the attached image.

Selection of elements does not work, only single element is exported. So the selection is not helpful in this case.
Comment 1 Kris Verlaenen 2013-09-30 20:49:38 EDT
Marek, I assume this is about the BPMN2 Eclipse Modeler?  No attached screenshot or linked Eclipse BZ?
Comment 2 Robert (Bob) Brodt 2013-10-08 11:56:33 EDT
Jiri, are you saying you want to restrict the captured image to the size of the editor window?

The bpmn2 editor delegates to an image capture/save dialog defined in the Graphiti framework. Maybe this enhancement request should be filed with the eclipse Graphiti project, otherwise I would have to duplicate a whole bunch of Graphiti internal code in the editor, just to override the current behavior.
Comment 3 Jiri Svitak 2013-10-09 08:32:30 EDT
Created attachment 809884 [details]
ParallelGateway.png

Bob,
No, the picture size already fitted to the size of the canvas. I want the size to be fitted to the size of the process.

I have attached how it looks now. It would be good to align this feature with web designer, it produces smaller image (fitted to process diagram size) than the attached one. Also designer produces .png with transparent background, it's a small thing, but could be useful as well.

It is not a serious issue, but it would be great if you could find a way to fix this without large workarounds because of graphiti.
Comment 4 Kris Verlaenen 2013-11-26 16:17:52 EST
Workaround exists (screenshot), this seems to be a bug in the underlying framework and unlikely to be fixed for v6.0

Note You need to log in before you can comment on or make changes to this bug.