Bug 1013 - printf with big field width segfaults:
Summary: printf with big field width segfaults:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libc (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-01 16:24 UTC by Christoph Rohland
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-11 22:29:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Rohland 1999-02-01 16:24:02 UTC
#include <stdio.h>

main()
{
    int ol = 1651, num = -4;
    for (ol=1040; ; ol++)
        printf ("%d: %0*ld\n",ol, ol, (long) num);
}

segfaults for ol > 1044

Comment 1 Anonymous 1999-02-18 13:02:59 UTC
Somebody out there?

Comment 2 Anonymous 1999-02-22 16:43:59 UTC
Since this request is not processed for a long time I opened the same
report at www-gnats.gnu.org request no 988. You can close this
request...


Note You need to log in before you can comment on or make changes to this bug.