Bug 1013014 - Software NMI with abrtd
Software NMI with abrtd
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.4
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: abrt
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 11:18 EDT by Christian Becker
Modified: 2017-12-06 07:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:55:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Becker 2013-09-27 11:18:50 EDT
Description of problem:
We were tracing a segfault within a third party package. But abrtd rejected the coredump with the message: Package 'php53u-fpm' isn't signed with proper key
So we added the signing key filename to /etc/abrt/gpg_keys and restarted abrtd afterwards. This worked well for a couple of minutes, so the application crashed and abrtd accepted the package. We now have some coredumps and aleady filed a bug for that.

After one of the crashes the server suddenly rebooted with the following Message on the Servers Lights Out Interface:

09/27/2013; 14:40:59	0x816f08132582ffff	System "SN# KD66BKR" has recovered from an Uncorrectable Bus Error
09/27/2013; 14:40:36	0x816f03131701ffff	System "SN# KD66BKR" has recovered from an NMI
09/27/2013; 14:40:25	0x806f08132582ffff	A Uncorrectable Bus Error has occurred on system "SN# KD66BKR"
09/27/2013; 14:39:16	0x806f03131701ffff	A software NMI has occurred on system "SN# KD66BKR"

The Server is a IBM System X 3650 M3 and we have seen this issue on two different Machines.

The /var/log/messages now contains no entries about that and we can't find any evidence for start of the crashkernel. Fortunately i had a less on /var/log/messages:

Sep 27 15:44:02 pay-web-1 kernel: php-fpm[1306]: segfault at 0 ip 00007f0276bbde52 sp 00007fff67010220 error 4 in libnss3.so (deleted)[7f0276b91000+135000]
Sep 27 15:44:02 pay-web-1 abrt[1609]: File '/usr/sbin/php-fpm' seems to be deleted
Sep 27 15:44:06 pay-web-1 abrt[1609]: Saved core dump of pid 1306 (/usr/sbin/php-fpm) to /var/spool/abrt/ccpp-2013-09-27-15:44:02-1306 (2167369728 bytes)
Sep 27 15:44:06 pay-web-1 abrtd: Directory 'ccpp-2013-09-27-15:44:02-1306' creation detected
Sep 27 15:44:06 pay-web-1 abrtd: Package 'php53u-fpm' isn't signed with proper key
Sep 27 15:44:06 pay-web-1 abrtd: 'post-create' on '/var/spool/abrt/ccpp-2013-09-27-15:44:02-1306' exited with 1
Sep 27 15:44:06 pay-web-1 abrtd: Corrupted or bad directory '/var/spool/abrt/ccpp-2013-09-27-15:44:02-1306', deleting
Sep 27 15:44:58 pay-web-1 abrtd: Got signal 15, exiting
Sep 27 15:44:58 pay-web-1 abrtd: Init complete, entering main loop
Sep 27 15:45:44 pay-web-1 kernel: php-fpm[32596]: segfault at 0 ip 00007f0276bbde52 sp 00007fff67010220 error 4 in libnss3.so (deleted)[7f0276b91000+135000]
Sep 27 15:45:44 pay-web-1 abrt[1704]: File '/usr/sbin/php-fpm' seems to be deleted
Sep 27 15:45:47 pay-web-1 abrt[1704]: Saved core dump of pid 32596 (/usr/sbin/php-fpm) to /var/spool/abrt/ccpp-2013-09-27-15:45:44-32596 (2171224064 bytes)
Sep 27 15:45:47 pay-web-1 abrtd: Directory 'ccpp-2013-09-27-15:45:44-32596' creation detected
Sep 27 15:45:48 pay-web-1 kernel: Bridge firewalling registered
Waiting for data... (interrupt to abort)Write failed: Broken pipe

Version-Release number of selected component (if applicable):
Version     : 2.0.8                             Vendor: Red Hat, Inc.
Release     : 15.el6                        Build Date: Wed Jan 23 17:51:05 2013

How reproducible:
- Had a segfaulting third party package causing the abrtd message: Package 'php53u-fpm' isn't signed with proper key
- Added /etc/pki/rpm-gpg/$KEY_FILE to /etc/abrt/gpg_keys
- /etc/init.d/abrtd restart
- segfault was triggered
- all fine!
- segfault was triggered
- Software NMI
Comment 2 RHEL Product and Program Management 2013-10-13 21:53:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Jan Kurik 2017-12-06 07:55:36 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.