Bug 1013017 - pkcsconf: C_GetSlotList returned 0 slots
pkcsconf: C_GetSlotList returned 0 slots
Status: CLOSED DUPLICATE of bug 1054442
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: opencryptoki (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Horák
Jiri Jaburek
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 11:22 EDT by Jiri Jaburek
Modified: 2014-01-20 08:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-20 08:21:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Jaburek 2013-09-27 11:22:43 EDT
Description of problem:

Any pkcsconf operation returns the following error:

C_GetSlotList returned 0 slots. Check that your tokens are installed correctly.

The opencryptoki-swtok package is installed, pkcsslotd is running without any apparent errors/warnings.

Copying RHEL6 binaries pkcs11_startup and pkcs_slot to this RHEL7 machine and run pkcs11_startup doesn't help, the error still appears.


Version-Release number of selected component (if applicable):
opencryptoki-swtok-3.0-4.el7.x86_64
opencryptoki-3.0-4.el7.x86_64
opencryptoki-libs-3.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. install aforementioned packages
2. start up pkcsslotd (if it's not running)
3. run ie. pkcsconf -t

Actual results:
pkcsconf -t outputs an error message

Expected results:
pkcsconf -t outputs info about tokens available (ie. soft token), like on RHEL6

Additional info:
Comment 1 Petr Lautrbach 2013-09-27 11:25:44 EDT
There's a problem with initialization of new software token. pkcs11_startup from older release can be used as temporary workaround.
Comment 4 Dan Horák 2014-01-13 05:03:41 EST
sounds bug #1045775 outlines a solution
Comment 5 Dan Horák 2014-01-20 08:21:02 EST

*** This bug has been marked as a duplicate of bug 1054442 ***

Note You need to log in before you can comment on or make changes to this bug.