Bug 1013032 - [as7] RHQ Server can get to state when it fails to deploy anything on underlying AS7
[as7] RHQ Server can get to state when it fails to deploy anything on underly...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 12:17 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 03:58:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-09-27 12:17:05 EDT
Description of problem: Right now I don't know what exactly happens to RHQ Server, but I can repeatedly get it (by running JON QE automation) to state when it fails to deploy anything (using UI/CLI/REST)


Version-Release number of selected component (if applicable):
RHQ 4.9.0


How reproducible: always


Steps to Reproduce:
1. run JON QE automation (sahi-core, cli-java-examples + other REST automation)
2. try deploy simple .war to RHQ Server resource

Actual results: deployment fails, AS7 server responds:

Operation <CompositeOperation{steps=2}> returned unparsable JSON, <"String index out of range: 0">., rolled-back=false


Expected results: Underlying AS7 should be able to deploy under any conditions


Additional info:

I need to make sure this is RHQ Server case only or same could be reproduced on stock EAP6.
Comment 1 Jay Shaughnessy 2014-06-27 16:09:14 EDT
Libor, is this a duplicate of Bug 1110881?
Comment 2 Libor Zoubek 2014-06-30 03:58:53 EDT
Yes, as I knew it was not supported, it worked for some time and when it stopped I thought it was bug.

Note You need to log in before you can comment on or make changes to this bug.