This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1013074 - katello-foreman-all should include dep for node-installer
katello-foreman-all should include dep for node-installer
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 15:03 EDT by Corey Welton
Modified: 2014-03-18 14:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 14:35:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-09-27 15:03:56 EDT
Description of problem:
we should include node-installer as dep fpr katello-foreman-all package so that we don't have to specify it separately.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum install -y katello-foreman-all node-installer.

Actual results:
We have to install both packages

Expected results:
we should just be able to pull in node-installer via katello-foreman-all

Additional info:
Comment 2 Mike McCune 2013-10-25 16:34:14 EDT
since a good portion of our users will be installing the smart proxy and nodes on different boxes lets put this off.  I'd rather keep it optional.
Comment 3 Mike McCune 2013-10-25 16:43:11 EDT
Once we switch to kafo for the entire installer we will need the above anyway.

Moving this to MDP3 to track to ensure we don't forget to add this top line dep.
Comment 4 Bryan Kearney 2014-03-18 14:35:02 EDT
This is no longer relevant.

Note You need to log in before you can comment on or make changes to this bug.