Bug 1013088 - [Doc] Following the keystone identity service steps results in configuration error message during token-get
[Doc] Following the keystone identity service steps results in configuration ...
Status: CLOSED DUPLICATE of bug 1101784
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Documentation Team
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 15:59 EDT by Jon Jozwiak
Modified: 2015-02-09 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-08 17:37:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Jozwiak 2013-09-27 15:59:15 EDT
Document URL: https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/pdf/Installation_and_Configuration_Guide/Red_Hat_OpenStack-3-Installation_and_Configuration_Guide-en-US.pdf

Section Number and Name: 5.10 Validating the Identity Service Installation

Describe the issue: If you follow the steps in chapter 5 for installing the Openstack Identity Service, the validation in section 5.10 fails on both the keystonerc_user being able to see users in the user-list as well as the keystone token-get failing.  

Suggestions for improvement: The problem is due to SERVICE_TOKEN and SERVICE_ENDPOINT still being set from section 5.6.  Add an additional step either after 5.6 on in 5.10 before doing any validation to unset the variables:
    unset SERVICE_TOKEN
    unset SERVICE_ENDPOINT 

Additional information: Here is the error given when running the keystone token-get:

[root@hostname ~(keystone_admin)]# keystone token-get
WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).
Configuration error: Client configured to run without a service catalog. Run the client using --os-auth-url or OS_AUTH_URL, instead of --os-endpoint or OS_SERVICE_ENDPOINT, for example.
Comment 2 Summer Long 2013-11-25 20:55:49 EST
Updating priority to match severity.
Comment 4 Andrew Dahms 2015-02-08 17:37:30 EST
Dear Jon,

Thank you for raising this bug, and my sincere apologies for the time it has taken to receive a response.

This issue is also raised in BZ#1101784, where work on this content is being consolidated.

I am closing this bug as a duplicate, but please let me know if you have any further issues with the documentation.

Kind regards,

Andrew

*** This bug has been marked as a duplicate of bug 1101784 ***

Note You need to log in before you can comment on or make changes to this bug.