Bug 1013159 - hwcert-backend submit tracebacks when listing files
hwcert-backend submit tracebacks when listing files
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1013865 1013646
  Show dependency treegraph
 
Reported: 2013-09-27 19:22 EDT by Rob Landry
Modified: 2013-11-13 04:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013646 1013865 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:58:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backend patch to warn and skip unparseable store directories (702 bytes, patch)
2013-09-30 09:35 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2013-09-27 19:22:55 EDT
Description of problem:

This might be related to the specific set of results I happen to have on this box but, when I run hwcert-backend submit I get...

    16 -> localhost 07-19-2013 at: 22:37 Cert ID: 886899 
         passed: memory, core  failed: suspend, info 

Arch: x86_64  OS: RHEL 6.4:

    17 -> localhost 07-15-2013 at: 20:21  
         failed: suspend, audio, info 
    18 -> localhost 07-15-2013 at: 20:43  
         failed: suspend, audio, info 
Traceback (most recent call last):
  File "/usr/bin/hwcert-backend", line 45, in <module>
    success = hwcertBackend.do(args)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 183, in do
    result = self.commands[self.command]()
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 332, in doSubmit
    (files, selection) = self.__selectFromStore("submitting to %s" % self.catalog.getCatalogServer())
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 342, in __selectFromStore
    resultsFiles = self.__showSaved(selection, summary)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 381, in __showSaved
    systemHeader =  "\n Arch: %s  OS: %s %s:\n" % (infoWords[4], infoWords[5], infoWords[6])
IndexError: list index out of range


Version-Release number of selected component (if applicable):

hwcert-client-1.6.5-16

How reproducible:

everytime


Steps to Reproduce:
1.run hwcert-backend submit
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Greg Nichols 2013-09-30 09:20:16 EDT
What do the directories /var/hwcert/store and /var/www/hwcert/store look like?  could you tar them and attach them?
Comment 2 Greg Nichols 2013-09-30 09:35:52 EDT
Created attachment 805213 [details]
backend patch to warn and skip unparseable store directories
Comment 3 Greg Nichols 2013-09-30 09:37:06 EDT
The above patch should fix the traceback.   The open issue is how the store directories on you system became unparseable.
Comment 4 Greg Nichols 2013-09-30 09:56:43 EDT
Patch committed to R17
Comment 7 Rob Landry 2013-09-30 19:05:24 EDT
Traceback is resolved although I have no idea from the output what file it's doesn't like.

 Arch: x86_64  OS: RHEL 6.4:

    18 -> localhost 07-15-2013 at: 20:21  
         failed: suspend, audio, info 
    19 -> localhost 07-15-2013 at: 20:43  
         failed: suspend, audio, info 
Warning: could not parse store directories for /var/www/hwcert/store

Select Results (<number>|all|none|quit|submit):
Comment 9 Brian Brock 2013-10-08 12:03:20 EDT
I don't hit the traceback either.

Marking as verified on 1.6.5-21.el6
Comment 11 errata-xmlrpc 2013-11-13 04:58:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.