Bug 101317 - easy configuration of zebra daemon parameters
Summary: easy configuration of zebra daemon parameters
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: zebra (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 20:39 UTC by Kaj J. Niemi
Modified: 2014-08-31 23:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-31 19:54:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against spec file (1.26 KB, patch)
2003-07-30 20:39 UTC, Kaj J. Niemi
no flags Details | Diff
Patch against zebra tree from SRPM (3.70 KB, patch)
2003-07-30 20:40 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2003-07-30 20:39:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030719
Mozilla Firebird/0.6

Description of problem:
Attached are patches against rawhide zebra 0.93-2 SRPM enabling the use of
parameters through /etc/sysconfig/zebra instead of editing
/etc/rc.d/init.d/{zebra,bgpd,ospfd}.

Please let me know if there is anything that should be changed before including
it in the next build. 

Many thanks.

Version-Release number of selected component (if applicable):
zebra-0.93-2

How reproducible:
Always

Steps to Reproduce:
1. Makes things easier, should be easy to reproduce ;-)
2.
3.
    

Actual Results:  Right now you need to edit each daemon separately and tamper
with the init file

Expected Results:  You should edit all of them in one place, in one file.

Additional info:

Works for me.

Comment 1 Kaj J. Niemi 2003-07-30 20:40:00 UTC
Created attachment 93273 [details]
Patch against spec file

Comment 2 Kaj J. Niemi 2003-07-30 20:40:45 UTC
Created attachment 93274 [details]
Patch against zebra tree from SRPM

Comment 3 Kaj J. Niemi 2003-08-26 07:09:05 UTC
This would apply against quagga too.

Comment 4 Kaj J. Niemi 2003-09-08 13:03:10 UTC
Well the patches above do not apply cleanly against quagga. I'll file a full
SRPM against quagga from rawhide once the component has been created. (#103946)

Comment 5 Kaj J. Niemi 2003-09-13 23:57:01 UTC
Component zebra, not qmkbootdisk.. geez, my bad. ;)

Comment 6 Kaj J. Niemi 2003-09-14 00:24:38 UTC
Just for reference.. equivalent functionality for quagga is in bug #104376. :)

Comment 7 Kaj J. Niemi 2003-10-23 22:50:11 UTC
If zebra is discontinued in rawhide this could just be resolved I think.

Comment 8 Jay Fenlason 2003-10-31 19:54:37 UTC
Since Zebra has been replaced with Quagga, and the Quagga RPM now has this 
functionality, I'm closing this bug. 


Note You need to log in before you can comment on or make changes to this bug.