Bug 1013215 - autofs: Resource temporarily unavailable
autofs: Resource temporarily unavailable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ian Kent
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-28 07:56 EDT by michu
Modified: 2013-10-15 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 22:08:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michu 2013-09-28 07:56:27 EDT
Description of problem:
Recently I updated my system. Autofs changed from 5.0.5-74 to 5.0.5-75, openssh client without changes, kernel changed from 2.6.39-400.24.1 to 2.6.39-400.209.1.

I had some autofs + fuse.sshfs mount points. Every 90 seconds autofs is disconnecting unused shares. When I try to access disconnected resource I got:

ls: cannot access /mnt/mydir: Resource temporarily unavailable

but after second ls its working as expected till next disconnect.

Version-Release number of selected component (if applicable):
Autofs 5.0.5-75

How reproducible:


Steps to Reproduce:
1. Configure autofs + fuse + sshfs
2. Auto Disconnect unused share
3. Try to reconnect

Actual results:


Expected results:
Fix.

Additional info:
Comment 2 Ian Kent 2013-09-30 20:18:22 EDT
(In reply to michu from comment #0)
> Description of problem:
> Recently I updated my system. Autofs changed from 5.0.5-74 to 5.0.5-75,
> openssh client without changes, kernel changed from 2.6.39-400.24.1 to
> 2.6.39-400.209.1.

These revisions don't make sense so I can't work out what
has changed.

Can you tell me more about the actual environment.

Ian
Comment 3 michu 2013-10-01 05:46:10 EDT
Hi Ian, 

Actually I'm using OEL 6.4 (basing on RHEL 6.4). I found that OEL version of this packages has one more patch applied since 5.0.5-74, so I assume the problem is not in RHEL, but in OEL. For now please close this bug report. Thank you.
Comment 4 RHEL Product and Program Management 2013-10-13 21:53:15 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.